Integer Overflow or Wraparound

Affecting gdk-pixbuf package, versions <2.36.5-2+deb9u2

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

Gnome gdk-pixbuf 2.36.8 and older is vulnerable to several integer overflow in the gif_get_lzw function resulting in memory corruption and potential code execution

References

CVSS Score

8.8
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVE
CVE-2017-1000422
CWE
CWE-190
Snyk ID
SNYK-DEBIAN9-GDKPIXBUF-344972
Disclosed
02 Jan, 2018
Published
02 Jan, 2018