Improper Initialization

Affecting exim4 package, versions <4.89-2+deb9u8

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream exim4 package. See Remediation section below for Debian:9 relevant versions.

Exim 4 before 4.94.2 has Improper Initialization that can lead to recursion-based stack consumption or other consequences. This occurs because use of certain getc functions is mishandled when a client uses BDAT instead of DATA.

Remediation

Upgrade Debian:9 exim4 to version 4.89-2+deb9u8 or higher.

References

CVSS Score

7.5
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    None
  • Availability
    High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVE
CVE-2020-28019
CWE
CWE-665
Snyk ID
SNYK-DEBIAN9-EXIM4-1279430
Disclosed
06 May, 2021
Published
05 May, 2021