Out-of-bounds Write

Affecting djvulibre package, versions <3.5.27.1-7+deb9u2

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream djvulibre package. See Remediation section below for Debian:9 relevant versions.

An out-of-bounds write vulnerability was found in DjVuLibre in DJVU::DjVuTXT::decode() in DjVuText.cpp via a crafted djvu file which may lead to crash and segmentation fault. This flaw affects DjVuLibre versions prior to 3.5.28.

Remediation

Upgrade Debian:9 djvulibre to version 3.5.27.1-7+deb9u2 or higher.

References

CVSS Score

5.5
medium severity
  • Attack Vector
    Local
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    None
  • Availability
    High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
CVE
CVE-2021-3630
CWE
CWE-787
Snyk ID
SNYK-DEBIAN9-DJVULIBRE-1315332
Disclosed
30 Jun, 2021
Published
01 Jul, 2021