Out-of-bounds Write

Affecting djvulibre package, versions <3.5.27.1-7+deb9u1

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream djvulibre package. See Remediation section below for Debian:9 relevant versions.

A flaw was found in djvulibre-3.5.28 and earlier. A heap buffer overflow in function DJVU::GBitmap::decode() via crafted djvu file may lead to application crash and other consequences.

Remediation

Upgrade Debian:9 djvulibre to version 3.5.27.1-7+deb9u1 or higher.

References

CVSS Score

7.8
high severity
  • Attack Vector
    Local
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVE
CVE-2021-32493
CWE
CWE-787
Snyk ID
SNYK-DEBIAN9-DJVULIBRE-1290635
Disclosed
24 Jun, 2021
Published
11 May, 2021