Improper Input Validation

Affecting apt package, versions <1.0.9

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream apt package. See Remediation section below for Debian:9 relevant versions.

APT before 1.0.9 does not "invalidate repository data" when moving from an unauthenticated to authenticated state, which allows remote attackers to have unspecified impact via crafted repository data.

Remediation

Upgrade Debian:9 apt to version 1.0.9 or higher.

References

CVSS Score

6.3
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    Low
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L
CVE
CVE-2014-0488
CWE
CWE-20
Snyk ID
SNYK-DEBIAN9-APT-407417
Disclosed
03 Nov, 2014
Published
03 Nov, 2014