Improper Input Validation

Affecting patch package, versions <2.7.5-1+deb8u1

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

GNU Patch version 2.7.6 contains an input validation vulnerability when processing patch files, specifically the EDITOR_PROGRAM invocation (using ed) can result in code execution. This attack appear to be exploitable via a patch file processed via the patch utility. This is similar to FreeBSD's CVE-2015-1418 however although they share a common ancestry the code bases have diverged over time.

References

CVSS Score

7.8
high severity
  • Attack Vector
    Local
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVE
CVE-2018-1000156
CWE
CWE-20
Snyk ID
SNYK-DEBIAN8-PATCH-303844
Disclosed
06 Apr, 2018
Published
06 Apr, 2018