Out-of-Bounds

Affecting libffi package, versions <3.1-2+deb8u1

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

libffi requests an executable stack allowing attackers to more easily trigger arbitrary code execution by overwriting the stack. Please note that libffi is used by a number of other libraries. It was previously stated that this affects libffi version 3.2.1 but this appears to be incorrect. libffi prior to version 3.1 on 32 bit x86 systems was vulnerable, and upstream is believed to have fixed this issue in version 3.1.

References

CVSS Score

7.0
high severity
  • Attack Vector
    Local
  • Attack Complexity
    High
  • Privileges Required
    Low
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
CVE
CVE-2017-1000376
CWE
CWE-119
Snyk ID
SNYK-DEBIAN8-LIBFFI-275801
Disclosed
19 Jun, 2017
Published
19 Jun, 2017