Cross-site Scripting (XSS)

Affecting jquery package, versions <1.7.2+dfsg-3.2+deb8u6

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream jquery package. See Remediation section below for Debian:8 relevant versions.

jQuery before 3.4.0, as used in Drupal, Backdrop CMS, and other products, mishandles jQuery.extend(true, {}, ...) because of Object.prototype pollution. If an unsanitized source object contained an enumerable proto property, it could extend the native Object.prototype.

Remediation

Upgrade Debian:8 jquery to version 1.7.2+dfsg-3.2+deb8u6 or higher.

References

CVSS Score

6.1
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Changed
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    None
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
CVE
CVE-2019-11358
CWE
CWE-79
Snyk ID
SNYK-DEBIAN8-JQUERY-344299
Disclosed
20 Apr, 2019
Published
20 Apr, 2019