Improper Encoding or Escaping of Output

Affecting git package, versions <1:2.0.0~rc2-1

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream git package. See Remediation section below for Debian:8 relevant versions.

contrib/completion/git-prompt.sh in Git before 1.9.3 does not sanitize branch names in the PS1 variable, allowing a malicious repository to cause code execution.

Remediation

Upgrade Debian:8 git to version 1:2.0.0~rc2-1 or higher.

References

CVSS Score

8.8
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVE
CVE-2014-9938
CWE
CWE-116
Snyk ID
SNYK-DEBIAN8-GIT-340923
Disclosed
20 Mar, 2017
Published
20 Mar, 2017