Improper Authentication

Affecting curl package, versions <7.38.0-4+deb8u13

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

curl and libcurl before 7.50.2, when built with NSS and the libnsspem.so library is available at runtime, allow remote attackers to hijack the authentication of a TLS connection by leveraging reuse of a previously loaded client certificate from file for a connection for which no certificate has been set, a different vulnerability than CVE-2016-5420.

References

CVSS Score

7.5
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    High
  • Availability
    None
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
CVE
CVE-2016-7141
CWE
CWE-287
Snyk ID
SNYK-DEBIAN8-CURL-358424
Disclosed
03 Oct, 2016
Published
03 Oct, 2016