Access Restriction Bypass

Affecting audit package, versions <1.5.3-2.1

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream audit package. See Remediation section below for Debian:8 relevant versions.

Stack-based buffer overflow in the audit_log_user_command function in lib/audit_logging.c in Linux Audit before 1.7 might allow remote attackers to execute arbitrary code via a long command argument. NOTE: some of these details are obtained from third party information.

Remediation

Upgrade Debian:8 audit to version 1.5.3-2.1 or higher.

References

CVSS Score

4.8
medium severity
  • Attack Vector
    Local
  • Attack Complexity
    Low
  • Privileges Required
    Low
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    Low
CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:L
CVE
CVE-2008-1628
CWE
CWE-119 CWE-264
Snyk ID
SNYK-DEBIAN8-AUDIT-288422
Disclosed
02 Apr, 2008
Published
02 Apr, 2008