Information Exposure

Affecting xorg-server package, versions <2:1.19.2-1

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream xorg-server package. See Remediation section below for Debian:10 relevant versions.

It was found that xorg-x11-server before 1.19.0 including uses memcmp() to check the received MIT cookie against a series of valid cookies. If the cookie is correct, it is allowed to attach to the Xorg session. Since most memcmp() implementations return after an invalid byte is seen, this causes a time difference between a valid and invalid byte, which could allow an efficient brute force attack.

Remediation

Upgrade Debian:10 xorg-server to version 2:1.19.2-1 or higher.

References

CVSS Score

7.0
low severity
  • Attack Vector
    Local
  • Attack Complexity
    High
  • Privileges Required
    Low
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
CVE
CVE-2017-2624
CWE
CWE-200
Snyk ID
SNYK-DEBIAN10-XORGSERVER-327012
Disclosed
27 Jul, 2018
Published
27 Jun, 2018