Out-of-bounds Write

Affecting tiff package, versions <4.1.0+git191117-2~deb10u1

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

tif_getimage.c in LibTIFF through 4.0.10, as used in GDAL through 3.0.1 and other products, has an integer overflow that potentially causes a heap-based buffer overflow via a crafted RGBA image, related to a "Negative-size-param" condition.

References

CVSS Score

8.8
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVE
CVE-2019-17546
CWE
CWE-190 CWE-787
Snyk ID
SNYK-DEBIAN10-TIFF-473083
Disclosed
14 Oct, 2019
Published
14 Oct, 2019