Off-by-one Error

Affecting sudo package, versions <1.8.27-1+deb10u3

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

Affected versions of this package are vulnerable to Off-by-one Error. Sudo before 1.9.5p2 contains an off-by-one error that can result in a heap-based buffer overflow, which allows privilege escalation to root via "sudoedit -s" and a command-line argument that ends with a single backslash character.

Remediation

Upgrade sudo to version or higher.

References

CVSS Score

7.8
high severity
  • Attack Vector
    Local
  • Attack Complexity
    Low
  • Privileges Required
    Low
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H/E:F
CVE
CVE-2021-3156
CWE
CWE-193
Snyk ID
SNYK-DEBIAN10-SUDO-1065093
Disclosed
26 Jan, 2021
Published
27 Jan, 2021