Improper Verification of Cryptographic Signature

Affecting python-apt package, versions <1.8.4.1

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream python-apt package. See Remediation section below for Debian:10 relevant versions.

Python-apt doesn't check if hashes are signed in Version.fetch_binary() and Version.fetch_source() of apt/package.py or in _fetch_archives() of apt/cache.py in version 1.9.3ubuntu2 and earlier. This allows downloads from unsigned repositories which shouldn't be allowed and has been fixed in verisions 1.9.5, 1.9.0ubuntu1.2, 1.6.5ubuntu0.1, 1.1.0~beta1ubuntu0.16.04.7, 0.9.3.5ubuntu3+esm2, and 0.8.3ubuntu7.5.

Remediation

Upgrade Debian:10 python-apt to version 1.8.4.1 or higher.

References

CVSS Score

4.7
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    High
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Changed
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    None
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N
CVE
CVE-2019-15796
CWE
CWE-347
Snyk ID
SNYK-DEBIAN10-PYTHONAPT-542697
Disclosed
26 Mar, 2020
Published
20 Jan, 2020