Out-of-bounds Write

Affecting pango1.0 package, versions <1.42.4-7~deb10u1

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

Gnome Pango 1.42 and later is affected by: Buffer Overflow. The impact is: The heap based buffer overflow can be used to get code execution. The component is: function name: pango_log2vis_get_embedding_levels, assignment of nchars and the loop condition. The attack vector is: Bug can be used when application pass invalid utf-8 strings to functions like pango_itemize.

References

CVSS Score

9.8
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVE
CVE-2019-1010238
CWE
CWE-787
Snyk ID
SNYK-DEBIAN10-PANGO10-456585
Disclosed
19 Jul, 2019
Published
04 Aug, 2019