Improper Authentication

Affecting openldap package, versions <2.4.47+dfsg-3+deb10u1

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

An issue was discovered in the server in OpenLDAP before 2.4.48. When the server administrator delegates rootDN (database admin) privileges for certain databases but wants to maintain isolation (e.g., for multi-tenant deployments), slapd does not properly stop a rootDN from requesting authorization as an identity from another database during a SASL bind or with a proxyAuthz (RFC 4370) control. (It is not a common configuration to deploy a system where the server administrator and a DB administrator enjoy different levels of trust.)

References

CVSS Score

4.9
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    High
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    None
  • Availability
    None
CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N
CVE
CVE-2019-13057
Snyk ID
SNYK-DEBIAN10-OPENLDAP-455344
Disclosed
26 Jul, 2019
Published
24 Jul, 2019