Out-of-bounds Write

Affecting openjpeg2 package, versions <2.3.0-2+deb10u2

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream openjpeg2 package. See Remediation section below for Debian:10 relevant versions.

A flaw was found in OpenJPEG’s encoder. This flaw allows an attacker to pass specially crafted x,y offset input to OpenJPEG to use during encoding. The highest threat from this vulnerability is to confidentiality, integrity, as well as system availability.

Remediation

Upgrade Debian:10 openjpeg2 to version 2.3.0-2+deb10u2 or higher.

References

CVSS Score

7.8
high severity
  • Attack Vector
    Local
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVE
CVE-2020-27823
CWE
CWE-120 CWE-787
Snyk ID
SNYK-DEBIAN10-OPENJPEG2-1049515
Disclosed
13 May, 2021
Published
09 Dec, 2020