Memory Leak

Affecting imagemagick package, versions <8:6.9.10.23+dfsg-2.1+deb10u1

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

In ImageMagick 7.0.8-36 Q16, there is a memory leak in the function SVGKeyValuePairs of coders/svg.c, which allows an attacker to cause a denial of service via a crafted image file.

References

CVSS Score

6.5
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    None
  • Availability
    High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
CVE
CVE-2019-10649
CWE
CWE-401
Snyk ID
SNYK-DEBIAN10-IMAGEMAGICK-341930
Disclosed
30 Mar, 2019
Published
30 Mar, 2019