Heap-based Buffer Overflow

Affecting imagemagick package, versions <0.0.0

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

Affected versions of this package are vulnerable to Heap-based Buffer Overflow. A heap based buffer overflow in coders/tiff.c may result in program crash and denial of service in ImageMagick before 7.0.10-45.

Remediation

Upgrade imagemagick to version 0 or higher.

References

CVSS Score

5.5
low severity
  • Attack Vector
    Local
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    None
  • Availability
    High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
CVE
CVE-2020-27829
CWE
CWE-122
Snyk ID
SNYK-DEBIAN10-IMAGEMAGICK-1070174
Disclosed
26 Mar, 2021
Published
05 Feb, 2021