Improper Input Validation

Affecting gnupg2 package, versions <2.0.26-5

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream gnupg2 package. See Remediation section below for Debian:10 relevant versions.

kbx/keybox-search.c in GnuPG before 1.4.19, 2.0.x before 2.0.27, and 2.1.x before 2.1.2 does not properly handle bitwise left-shifts, which allows remote attackers to cause a denial of service (invalid read operation) via a crafted keyring file, related to sign extensions and "memcpy with overlapping ranges."

Remediation

Upgrade Debian:10 gnupg2 to version 2.0.26-5 or higher.

References

CVSS Score

5.5
medium severity
  • Attack Vector
    Local
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    None
  • Availability
    High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
CVE
CVE-2015-1607
CWE
CWE-20
Snyk ID
SNYK-DEBIAN10-GNUPG2-340456
Disclosed
20 Nov, 2019
Published
27 Jun, 2018