Use After Free

Affecting gnupg2 package, versions <2.0.26-5

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream gnupg2 package. See Remediation section below for Debian:10 relevant versions.

The keyring DB in GnuPG before 2.1.2 does not properly handle invalid packets, which allows remote attackers to cause a denial of service (invalid read and use-after-free) via a crafted keyring file.

Remediation

Upgrade Debian:10 gnupg2 to version 2.0.26-5 or higher.

References

CVSS Score

5.5
medium severity
  • Attack Vector
    Local
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    None
  • Availability
    High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
CVE
CVE-2015-1606
CWE
CWE-416
Snyk ID
SNYK-DEBIAN10-GNUPG2-340436
Disclosed
20 Nov, 2019
Published
27 Jun, 2018