Buffer Overflow

Affecting exim4 package, versions <4.92-8+deb10u3

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

Exim 4.92 through 4.92.2 allows remote code execution, a different vulnerability than CVE-2019-15846. There is a heap-based buffer overflow in string_vformat in string.c involving a long EHLO command.

References

CVSS Score

9.8
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVE
CVE-2019-16928
CWE
CWE-120
Snyk ID
SNYK-DEBIAN10-EXIM4-469258
Disclosed
27 Sep, 2019
Published
27 Sep, 2019