Access Restriction Bypass

Affecting cups package, versions <1.5.3-2.7

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream cups package. See Remediation section below for Debian:10 relevant versions.

CUPS 1.4.4, when running in certain Linux distributions such as Debian GNU/Linux, stores the web interface administrator key in /var/run/cups/certs/0 using certain permissions, which allows local users in the lpadmin group to read or write arbitrary files as root by leveraging the web interface.

Remediation

Upgrade Debian:10 cups to version 1.5.3-2.7 or higher.

References

CVSS Score

8.4
high severity
  • Attack Vector
    Local
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVE
CVE-2012-5519
CWE
CWE-264
Snyk ID
SNYK-DEBIAN10-CUPS-364360
Disclosed
20 Nov, 2012
Published
20 Nov, 2012