Arbitrary Code Injection

Affecting ruby package, versions <2.5.7-r0

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

Ruby through 2.4.7, 2.5.x through 2.5.6, and 2.6.x through 2.6.4 allows code injection if the first argument (aka the "command" argument) to Shell#[] or Shell#test in lib/shell.rb is untrusted data. An attacker can exploit this to call an arbitrary Ruby method.

References

CVSS Score

8.1
high severity
  • Attack Vector
    Network
  • Attack Complexity
    High
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
CVE
CVE-2019-16255
CWE
CWE-94
Snyk ID
SNYK-ALPINE39-RUBY-489096
Disclosed
26 Nov, 2019
Published
13 Nov, 2019