Out-of-bounds Write

Affecting postgresql package, versions <11.4-r0

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

PostgreSQL versions 10.x before 10.9 and versions 11.x before 11.4 are vulnerable to a stack-based buffer overflow. Any authenticated user can overflow a stack-based buffer by changing the user's own password to a purpose-crafted value. This often suffices to execute arbitrary code as the PostgreSQL operating system account.

References

CVSS Score

8.8
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    Low
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVE
CVE-2019-10164
CWE
CWE-121 CWE-787
Snyk ID
SNYK-ALPINE39-POSTGRESQL-452890
Disclosed
26 Jun, 2019
Published
23 Jun, 2019