Race Condition

Affecting libgcrypt package, versions <1.8.5-r0

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

It was discovered that there was a ECDSA timing attack in the libgcrypt20 cryptographic library. Version affected: 1.8.4-5, 1.7.6-2+deb9u3, and 1.6.3-2+deb8u4. Versions fixed: 1.8.5-2 and 1.6.3-2+deb8u7.

References

CVSS Score

6.3
medium severity
  • Attack Vector
    Local
  • Attack Complexity
    High
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    None
CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N
CVE
CVE-2019-13627
CWE
CWE-362
Snyk ID
SNYK-ALPINE39-LIBGCRYPT-484050
Disclosed
25 Sep, 2019
Published
29 Aug, 2019