ssr-types@0.4.5

Vulnerabilities

1 via 1 paths

Dependencies

183

Source

npm

Find, fix and prevent vulnerabilities in your code.

Severity
  • 1
Status
  • 1
  • 0
  • 0

high severity

Command Injection

  • Vulnerable module: lodash.template
  • Introduced through: @midwayjs/faas@1.2.17

Detailed paths

  • Introduced through: ssr-types@0.4.5 @midwayjs/faas@1.2.17 @midwayjs/core@2.12.1 lodash.template@4.5.0

Overview

lodash.template is a The Lodash method _.template exported as a Node.js module.

Affected versions of this package are vulnerable to Command Injection via template.

PoC

var _ = require('lodash');

_.template('', { variable: '){console.log(process.env)}; with(obj' })()

Remediation

There is no fixed version for lodash.template.

References