smart-id-rest@1.1.0

Vulnerabilities

1 via 1 paths

Dependencies

43

Source

npm

Find, fix and prevent vulnerabilities in your code.

Severity
  • 1
Status
  • 1
  • 0
  • 0

medium severity

Cryptographic Issues

  • Vulnerable module: elliptic
  • Introduced through: elliptic@6.5.3

Detailed paths

  • Introduced through: smart-id-rest@1.1.0 elliptic@6.5.3
    Remediation: Upgrade to smart-id-rest@1.2.1.

Overview

elliptic is a Fast elliptic-curve cryptography in a plain javascript implementation.

Affected versions of this package are vulnerable to Cryptographic Issues via the secp256k1 implementation in elliptic/ec/key.js. There is no check to confirm that the public key point passed into the derive function actually exists on the secp256k1 curve. This results in the potential for the private key used in this implementation to be revealed after a number of ECDH operations are performed.

Remediation

Upgrade elliptic to version 6.5.4 or higher.

References