seneca@3.8.4

Vulnerabilities 1 via 1 paths
Dependencies 44
Source npm
Package seneca

Find, fix and prevent vulnerabilities in your code.

Severity
  • 1
Status
  • 1
  • 0
  • 0
low severity

Information Exposure

  • Vulnerable module: seneca
  • Introduced through: seneca@3.8.4

Detailed paths

  • Introduced through: seneca@3.8.4
    Remediation: Upgrade to seneca@3.9.0.

Overview

seneca is a Node.js toolkit for Microservice architectures.

Affected versions of this package are vulnerable to Information Exposure. When a process using Seneca crashes, it prints out all of its environment variables.

Remediation

Upgrade seneca to version 3.9.0 or higher.

References