sacoin@1.0.5

Vulnerabilities

2 via 2 paths

Dependencies

511

Source

npm

Find, fix and prevent vulnerabilities in your code.

Severity
  • 1
  • 1
Status
  • 2
  • 0
  • 0

high severity

Insecure Randomness

  • Vulnerable module: crypto-js
  • Introduced through: merkletreejs@0.1.11

Detailed paths

  • Introduced through: sacoin@1.0.5 merkletreejs@0.1.11 crypto-js@3.3.0

Overview

crypto-js is a library of crypto standards.

Affected versions of this package are vulnerable to Insecure Randomness. The secureRandom() method is supposed to return a cryptographically strong pseudo-random data string, but it is biased to certain digits. An attacker could be able to guess the created digits.

Remediation

Upgrade crypto-js to version 4.0.0, 3.2.1 or higher.

References

medium severity

Cryptographic Weakness

  • Vulnerable module: jsrsasign
  • Introduced through: jsrsasign@8.0.24

Detailed paths

  • Introduced through: sacoin@1.0.5 jsrsasign@8.0.24
    Remediation: Upgrade to jsrsasign@10.1.13.

Overview

jsrsasign is a free pure JavaScript cryptographic library.

Affected versions of this package are vulnerable to Cryptographic Weakness. Invalid RSA PKCS#1 v1.5 signatures are mistakenly recognized to be valid.

Remediation

Upgrade jsrsasign to version 10.1.13 or higher.

References