Vulnerabilities

4 via 4 paths

Dependencies

268

Source

npm

Find, fix and prevent vulnerabilities in your code.

Severity
  • 2
  • 2
Status
  • 4
  • 0
  • 0

high severity

Remote Code Execution (RCE)

  • Vulnerable module: shell-quote
  • Introduced through: @next/react-dev-overlay@11.1.3-canary.18

Detailed paths

  • Introduced through: next@11.1.3-canary.18 @next/react-dev-overlay@11.1.3-canary.18 shell-quote@1.7.2

Overview

shell-quote is a package used to quote and parse shell commands.

Affected versions of this package are vulnerable to Remote Code Execution (RCE). An attacker can inject unescaped shell metacharacters through a regex designed to support Windows drive letters. If the output of this package is passed to a real shell as a quoted argument to a command with exec(), an attacker can inject arbitrary commands. This is because the Windows drive letter regex character class is {A-z] instead of the correct {A-Za-z]. Several shell metacharacters exist in the space between capital letter Z and lower case letter a, such as the backtick character.

Remediation

Upgrade shell-quote to version 1.7.3 or higher.

References

high severity

Denial of Service (DoS)

  • Vulnerable module: next
  • Introduced through: next@11.1.3-canary.18

Detailed paths

  • Introduced through: next@11.1.3-canary.18
    Remediation: Upgrade to next@11.1.3.

Overview

next is a react framework.

Affected versions of this package are vulnerable to Denial of Service (DoS) due to mishandling of invalid URLs. Note: This vulnerability is only possible for Node.js versions of 15.0.0 and above. Also, deployments on Vercel (vercel.com) are not affected along with similar environments where invalid requests are filtered before reaching Next.js.

Details

Denial of Service (DoS) describes a family of attacks, all aimed at making a system inaccessible to its intended and legitimate users.

Unlike other vulnerabilities, DoS attacks usually do not aim at breaching security. Rather, they are focused on making websites and services unavailable to genuine users resulting in downtime.

One popular Denial of Service vulnerability is DDoS (a Distributed Denial of Service), an attack that attempts to clog network pipes to the system by generating a large volume of traffic from many machines.

When it comes to open source libraries, DoS vulnerabilities allow attackers to trigger such a crash or crippling of the service by using a flaw either in the application code or from the use of open source libraries.

Two common types of DoS vulnerabilities:

  • High CPU/Memory Consumption- An attacker sending crafted requests that could cause the system to take a disproportionate amount of time to process. For example, commons-fileupload:commons-fileupload.

  • Crash - An attacker sending crafted requests that could cause the system to crash. For Example, npm ws package

Remediation

Upgrade next to version 12.0.5, 11.1.3 or higher.

References

medium severity

Information Exposure

  • Vulnerable module: node-fetch
  • Introduced through: node-fetch@2.6.1

Detailed paths

  • Introduced through: next@11.1.3-canary.18 node-fetch@2.6.1
    Remediation: Upgrade to next@11.1.4.

Overview

node-fetch is a light-weight module that brings window.fetch to node.js

Affected versions of this package are vulnerable to Information Exposure when fetching a remote url with Cookie, if it get a Location response header, it will follow that url and try to fetch that url with provided cookie. This can lead to forwarding secure headers to 3th party.

Remediation

Upgrade node-fetch to version 2.6.7, 3.1.1 or higher.

References

medium severity

User Interface (UI) Misrepresentation of Critical Information

  • Vulnerable module: next
  • Introduced through: next@11.1.3-canary.18

Detailed paths

  • Introduced through: next@11.1.3-canary.18
    Remediation: Upgrade to next@12.1.0.

Overview

next is a react framework.

Affected versions of this package are vulnerable to User Interface (UI) Misrepresentation of Critical Information due to improper CSP (content security policy).

Note: In order to be affected ALL of the following must be true:

  1. Next.js between version 10.0.0 and 12.0.10.

  2. The next.config.js file has images.domains array assigned.

  3. The image host assigned in images.domains allows user-provided SVG

Not affected: The next.config.js file has images.loader assigned to something other than "default".

Remediation

Upgrade next to version 12.1.0 or higher.

References