nest-cisco-webdialer-client@1.0.4

Vulnerabilities

4 via 4 paths

Dependencies

145

Source

npm

Find, fix and prevent vulnerabilities in your code.

Severity
  • 1
  • 2
  • 1
Status
  • 4
  • 0
  • 0

high severity

Signature Validation Bypass

  • Vulnerable module: xml-crypto
  • Introduced through: soap@0.30.0

Detailed paths

  • Introduced through: nest-cisco-webdialer-client@1.0.4 soap@0.30.0 xml-crypto@1.5.3
    Remediation: Upgrade to soap@0.35.0.

Overview

xml-crypto is a xml digital signature and encryption library for Node.js.

Affected versions of this package are vulnerable to Signature Validation Bypass. An attacker can inject an HMAC-SHA1 signature that is valid using only knowledge of the RSA public key. This allows bypassing signature validation.

Remediation

Upgrade xml-crypto to version 2.0.0 or higher.

References

medium severity

Server-Side Request Forgery (SSRF)

  • Vulnerable module: axios
  • Introduced through: @nestjs/common@6.11.11

Detailed paths

  • Introduced through: nest-cisco-webdialer-client@1.0.4 @nestjs/common@6.11.11 axios@0.19.2
    Remediation: Upgrade to @nestjs/common@7.6.5.

Overview

axios is a promise based HTTP client for the browser and node.js.

Affected versions of this package are vulnerable to Server-Side Request Forgery (SSRF). An attacker is able to bypass a proxy by providing a URL that responds with a redirect to a restricted host or IP address.

Remediation

Upgrade axios to version 0.21.1 or higher.

References

medium severity

XML External Entity (XXE) Injection

  • Vulnerable module: xmldom
  • Introduced through: soap@0.30.0

Detailed paths

  • Introduced through: nest-cisco-webdialer-client@1.0.4 soap@0.30.0 xml-crypto@1.5.3 xmldom@0.1.27
    Remediation: Upgrade to soap@0.35.0.

Overview

xmldom is an A pure JavaScript W3C standard-based (XML DOM Level 2 Core) DOMParser and XMLSerializer module.

Affected versions of this package are vulnerable to XML External Entity (XXE) Injection. Does not correctly preserve system identifiers, FPIs or namespaces when repeatedly parsing and serializing maliciously crafted documents.

Details

XXE Injection is a type of attack against an application that parses XML input. XML is a markup language that defines a set of rules for encoding documents in a format that is both human-readable and machine-readable. By default, many XML processors allow specification of an external entity, a URI that is dereferenced and evaluated during XML processing. When an XML document is being parsed, the parser can make a request and include the content at the specified URI inside of the XML document.

Attacks can include disclosing local files, which may contain sensitive data such as passwords or private user data, using file: schemes or relative paths in the system identifier.

For example, below is a sample XML document, containing an XML element- username.

<?xml version="1.0" encoding="ISO-8859-1"?>
   <username>John</username>
</xml>

An external XML entity - xxe, is defined using a system identifier and present within a DOCTYPE header. These entities can access local or remote content. For example the below code contains an external XML entity that would fetch the content of /etc/passwd and display it to the user rendered by username.

<?xml version="1.0" encoding="ISO-8859-1"?>
<!DOCTYPE foo [
   <!ENTITY xxe SYSTEM "file:///etc/passwd" >]>
   <username>&xxe;</username>
</xml>

Other XXE Injection attacks can access local resources that may not stop returning data, possibly impacting application availability and leading to Denial of Service.

Remediation

Upgrade xmldom to version 0.5.0 or higher.

References

low severity

Arbitrary Code Injection

  • Vulnerable module: underscore
  • Introduced through: soap@0.30.0

Detailed paths

  • Introduced through: nest-cisco-webdialer-client@1.0.4 soap@0.30.0 httpntlm@1.7.6 underscore@1.7.0

Overview

underscore is a JavaScript's functional programming helper library.

Affected versions of this package are vulnerable to Arbitrary Code Injection via the template function, particularly when the variable option is taken from _.templateSettings as it is not sanitized.

PoC

const _ = require('underscore');
_.templateSettings.variable = "a = this.process.mainModule.require('child_process').execSync('touch HELLO')";
const t = _.template("")();

Remediation

Upgrade underscore to version 1.13.0-2, 1.12.1 or higher.

References