launchdarkly-api@3.9.2

Vulnerabilities

1 via 1 paths

Dependencies

31

Source

npm

Find, fix and prevent vulnerabilities in your code.

Severity
  • 1
Status
  • 1
  • 0
  • 0

medium severity

Information Exposure

  • Vulnerable module: superagent
  • Introduced through: superagent@3.7.0

Detailed paths

  • Introduced through: launchdarkly-api@3.9.2 superagent@3.7.0
    Remediation: Upgrade to superagent@3.8.1.

Overview

superagent is a Small progressive client-side HTTP request library, and Node.js module with the same API, supporting many high-level HTTP client features.

Affected versions of this package are vulnerable to Information Exposure due to sending the contents of Authorization to third parties.

Remediation

Upgrade superagent to version 3.8.1 or higher.

References