engage-ui@1.44.0

Vulnerabilities

2 via 2 paths

Dependencies

287

Source

npm

Find, fix and prevent vulnerabilities in your code.

Severity
  • 2
Status
  • 2
  • 0
  • 0

medium severity

new

Server-Side Request Forgery (SSRF)

  • Vulnerable module: axios
  • Introduced through: axios@0.18.1

Detailed paths

  • Introduced through: engage-ui@1.44.0 axios@0.18.1

Overview

axios is a promise based HTTP client for the browser and node.js.

Affected versions of this package are vulnerable to Server-Side Request Forgery (SSRF). An attacker is able to bypass a proxy by providing a URL that responds with a redirect to a restricted host or IP address.

Remediation

There is no fixed version for axios.

References

medium severity

Denial of Service

  • Vulnerable module: node-fetch
  • Introduced through: react-addons-shallow-compare@15.6.2

Detailed paths

  • Introduced through: engage-ui@1.44.0 react-addons-shallow-compare@15.6.2 fbjs@0.8.17 isomorphic-fetch@2.2.1 node-fetch@1.7.3

Overview

node-fetch is an A light-weight module that brings window.fetch to node.js

Affected versions of this package are vulnerable to Denial of Service. Node Fetch did not honor the size option after following a redirect, which means that when a content size was over the limit, a FetchError would never get thrown and the process would end without failure.

Remediation

Upgrade node-fetch to version 2.6.1, 3.0.0-beta.9 or higher.

References