bunjil@1.0.9

Vulnerabilities

1 via 1 paths

Dependencies

297

Source

npm

Package

bunjil

Find, fix and prevent vulnerabilities in your code.

Severity
  • 1
Status
  • 1
  • 0
  • 0

high severity

Information Exposure

  • Vulnerable module: apollo-server-core
  • Introduced through: apollo-server-koa@1.4.0

Detailed paths

  • Introduced through: bunjil@1.0.9 apollo-server-koa@1.4.0 apollo-server-core@1.4.0
    Remediation: Upgrade to apollo-server-koa@2.1.0.

Overview

apollo-server-core is a core module of the Apollo community GraphQL Server.

Affected versions of this package are vulnerable to Information Exposure. It does not properly enforce validation rules when creating subscription servers, which includes a NoInstrospection rule for the Websocket. This leaks the GraphQL schema types, their relations and human-readable names.

Remediation

Upgrade apollo-server-core to version 2.4.12 or higher.

References