@gnosis.pm/safe-modules@0.1.0

Vulnerabilities

2 via 9 paths

Dependencies

444

Source

npm

Find, fix and prevent vulnerabilities in your code.

Severity
  • 1
  • 1
Status
  • 2
  • 0
  • 0

medium severity

Denial of Service

  • Vulnerable module: node-fetch
  • Introduced through: @gnosis.pm/safe-contracts@0.1.0 and @gnosis.pm/util-contracts@2.0.7

Detailed paths

  • Introduced through: @gnosis.pm/safe-modules@0.1.0 @gnosis.pm/safe-contracts@0.1.0 truffle-hdwallet-provider@0.0.7-beta.1 web3-provider-engine@14.2.1 cross-fetch@2.2.3 node-fetch@2.1.2
  • Introduced through: @gnosis.pm/safe-modules@0.1.0 @gnosis.pm/util-contracts@2.0.7 @truffle/hdwallet-provider@1.2.6 @trufflesuite/web3-provider-engine@15.0.13-1 cross-fetch@2.2.3 node-fetch@2.1.2
  • Introduced through: @gnosis.pm/safe-modules@0.1.0 @gnosis.pm/safe-contracts@0.1.0 truffle-hdwallet-provider@0.0.7-beta.1 web3-provider-engine@14.2.1 eth-json-rpc-infura@3.2.1 cross-fetch@2.2.3 node-fetch@2.1.2
  • Introduced through: @gnosis.pm/safe-modules@0.1.0 @gnosis.pm/util-contracts@2.0.7 @truffle/hdwallet-provider@1.2.6 @trufflesuite/web3-provider-engine@15.0.13-1 @trufflesuite/eth-json-rpc-infura@4.0.3-0 cross-fetch@2.2.3 node-fetch@2.1.2
  • Introduced through: @gnosis.pm/safe-modules@0.1.0 @gnosis.pm/util-contracts@2.0.7 @truffle/hdwallet-provider@1.2.6 @trufflesuite/web3-provider-engine@15.0.13-1 @trufflesuite/eth-json-rpc-middleware@4.4.2-1 fetch-ponyfill@4.1.0 node-fetch@1.7.3
  • Introduced through: @gnosis.pm/safe-modules@0.1.0 @gnosis.pm/safe-contracts@0.1.0 truffle-hdwallet-provider@0.0.7-beta.1 web3-provider-engine@14.2.1 eth-json-rpc-infura@3.2.1 eth-json-rpc-middleware@1.6.0 fetch-ponyfill@4.1.0 node-fetch@1.7.3
  • Introduced through: @gnosis.pm/safe-modules@0.1.0 @gnosis.pm/util-contracts@2.0.7 @truffle/hdwallet-provider@1.2.6 @trufflesuite/web3-provider-engine@15.0.13-1 @trufflesuite/eth-json-rpc-filters@4.1.2-1 @trufflesuite/eth-json-rpc-middleware@4.4.2-1 fetch-ponyfill@4.1.0 node-fetch@1.7.3
  • Introduced through: @gnosis.pm/safe-modules@0.1.0 @gnosis.pm/util-contracts@2.0.7 @truffle/hdwallet-provider@1.2.6 @trufflesuite/web3-provider-engine@15.0.13-1 @trufflesuite/eth-json-rpc-infura@4.0.3-0 @trufflesuite/eth-json-rpc-middleware@4.4.2-1 fetch-ponyfill@4.1.0 node-fetch@1.7.3

Overview

node-fetch is an A light-weight module that brings window.fetch to node.js

Affected versions of this package are vulnerable to Denial of Service. Node Fetch did not honor the size option after following a redirect, which means that when a content size was over the limit, a FetchError would never get thrown and the process would end without failure.

Remediation

Upgrade node-fetch to version 2.6.1, 3.0.0-beta.9 or higher.

References

low severity

Insecure Credential Storage

  • Vulnerable module: web3
  • Introduced through: @gnosis.pm/safe-contracts@0.1.0

Detailed paths

  • Introduced through: @gnosis.pm/safe-modules@0.1.0 @gnosis.pm/safe-contracts@0.1.0 truffle-hdwallet-provider@0.0.7-beta.1 web3@0.18.4

Overview

web3 is a JavaScript API which connects to the Generic JSON RPC spec.

Affected versions of this package are vulnerable to Insecure Credential Storage. The current implementation of web3.js could result in wallet decryption under certain circumstances. When a wallet is saved and encrypted into local storage, a private key is needed to load the wallet. However, this private key is available via LocalStorage and is readable in plaintext on a webpage after a wallet is loaded.

This implementation could be abused by an attacker through client-side attacks such as Cross-site Scripting (XSS) and could result in theft of a user's wallet private key.

Remediation

There is no fixed version for web3.

References