Vulnerabilities |
3 via 3 paths |
|---|---|
Dependencies |
88 |
Source |
GitHub |
Find, fix and prevent vulnerabilities in your code.
high severity
- Vulnerable module: http-cache-semantics
- Introduced through: got@10.7.0
Detailed paths
-
Introduced through: usrnme@tylerdevs/usrnme › got@10.7.0 › cacheable-request@7.0.4 › http-cache-semantics@4.3.0
Overview
Affected versions of this package are vulnerable to Improper Authorization via improper validation of security-zeroed cache entries when processing client max-stale directives. An unauthenticated attacker can request the same URL with a large max-stale value to retrieve cached responses belonging to other users, including Set-Cookie session credentials from shared-cache entries that were deliberately zeroed for security reasons.
Remediation
There is no fixed version for http-cache-semantics.
References
high severity
- Vulnerable module: http-cache-semantics
- Introduced through: got@10.7.0
Detailed paths
-
Introduced through: usrnme@tylerdevs/usrnme › got@10.7.0 › cacheable-request@7.0.4 › http-cache-semantics@4.3.0
Overview
Affected versions of this package are vulnerable to Origin Validation Error via the _varyMatches() function, which fails to properly handle Vary: * (wildcard) headers due to byte-for-byte string comparison. An attacker can request URLs previously fetched by other clients to receive cached responses intended for different users, disclosing sensitive information across clients. The Vary: * directive signals that a response is uncacheable for any other request, but the flawed comparison allows the wildcard to be bypassed, enabling cross-client cache disclosure.
Remediation
There is no fixed version for http-cache-semantics.
References
medium severity
- Vulnerable module: got
- Introduced through: got@10.7.0
Detailed paths
-
Introduced through: usrnme@tylerdevs/usrnme › got@10.7.0Remediation: Upgrade to got@11.8.5.
Overview
Affected versions of this package are vulnerable to Open Redirect due to missing verification of requested URLs. It allowed a victim to be redirected to a UNIX socket.
Remediation
Upgrade got to version 11.8.5, 12.1.0 or higher.