Vulnerabilities

3 via 3 paths

Dependencies

304

Source

GitHub

Commit

19036fb1

Find, fix and prevent vulnerabilities in your code.

Severity
  • 3
Status
  • 3
  • 0
  • 0

medium severity

Information Exposure

  • Vulnerable module: node-fetch
  • Introduced through: quicktype-core@6.1.0

Detailed paths

  • Introduced through: typewriter@segmentio/typewriter#19036fb1ed417e29504d341d709e880f80cea7e9 quicktype-core@6.1.0 isomorphic-fetch@2.2.1 node-fetch@1.7.3

Overview

node-fetch is a light-weight module that brings window.fetch to node.js

Affected versions of this package are vulnerable to Information Exposure when fetching a remote url with Cookie, if it get a Location response header, it will follow that url and try to fetch that url with provided cookie. This can lead to forwarding secure headers to 3th party.

Remediation

Upgrade node-fetch to version 2.6.7, 3.1.1 or higher.

References

medium severity

Denial of Service

  • Vulnerable module: node-fetch
  • Introduced through: quicktype-core@6.1.0

Detailed paths

  • Introduced through: typewriter@segmentio/typewriter#19036fb1ed417e29504d341d709e880f80cea7e9 quicktype-core@6.1.0 isomorphic-fetch@2.2.1 node-fetch@1.7.3

Overview

node-fetch is a light-weight module that brings window.fetch to node.js

Affected versions of this package are vulnerable to Denial of Service. Node Fetch did not honor the size option after following a redirect, which means that when a content size was over the limit, a FetchError would never get thrown and the process would end without failure.

Remediation

Upgrade node-fetch to version 2.6.1, 3.0.0-beta.9 or higher.

References

medium severity

Open Redirect

  • Vulnerable module: got
  • Introduced through: latest-version@5.1.0

Detailed paths

  • Introduced through: typewriter@segmentio/typewriter#19036fb1ed417e29504d341d709e880f80cea7e9 latest-version@5.1.0 package-json@6.5.0 got@9.6.0
    Remediation: Upgrade to latest-version@6.0.0.

Overview

Affected versions of this package are vulnerable to Open Redirect due to missing verification of requested URLs. It allowed a victim to be redirected to a UNIX socket.

Remediation

Upgrade got to version 11.8.5, 12.1.0 or higher.

References