Vulnerabilities

2 via 7 paths

Dependencies

296

Source

GitHub

Find, fix and prevent vulnerabilities in your code.

Severity
  • 2
Status
  • 2
  • 0
  • 0

medium severity
new

Information Exposure

  • Vulnerable module: node-fetch
  • Introduced through: bcrypt@5.0.1 and apollo-server-express@3.6.1

Detailed paths

  • Introduced through: clean-node-api@rmanguinho/clean-ts-api bcrypt@5.0.1 @mapbox/node-pre-gyp@1.0.8 node-fetch@2.6.7
  • Introduced through: clean-node-api@rmanguinho/clean-ts-api apollo-server-express@3.6.1 apollo-server-types@3.5.0 apollo-server-env@4.2.0 node-fetch@2.6.7
  • Introduced through: clean-node-api@rmanguinho/clean-ts-api apollo-server-express@3.6.1 apollo-server-core@3.6.1 apollo-server-env@4.2.0 node-fetch@2.6.7
  • Introduced through: clean-node-api@rmanguinho/clean-ts-api apollo-server-express@3.6.1 apollo-server-core@3.6.1 apollo-datasource@3.3.0 apollo-server-env@4.2.0 node-fetch@2.6.7
  • Introduced through: clean-node-api@rmanguinho/clean-ts-api apollo-server-express@3.6.1 apollo-server-core@3.6.1 apollo-server-types@3.5.0 apollo-server-env@4.2.0 node-fetch@2.6.7
  • Introduced through: clean-node-api@rmanguinho/clean-ts-api apollo-server-express@3.6.1 apollo-server-core@3.6.1 apollo-server-plugin-base@3.5.0 apollo-server-types@3.5.0 apollo-server-env@4.2.0 node-fetch@2.6.7

Overview

node-fetch is a light-weight module that brings window.fetch to node.js

Affected versions of this package are vulnerable to Information Exposure when fetching a remote url with Cookie, if it get a Location response header, it will follow that url and try to fetch that url with provided cookie. This can lead to forwarding secure headers to 3th party.

Remediation

Upgrade node-fetch to version 3.1.1 or higher.

References

medium severity

User Interface (UI) Misrepresentation of Critical Information

  • Vulnerable module: swagger-ui-dist
  • Introduced through: swagger-ui-express@4.3.0

Detailed paths

  • Introduced through: clean-node-api@rmanguinho/clean-ts-api swagger-ui-express@4.3.0 swagger-ui-dist@4.1.3

Overview

swagger-ui-dist is a module that exposes Swagger-UI's entire dist folder as a dependency-free npm module. Use swagger-ui instead, if you'd like to have npm install dependencies for you.

Affected versions of this package are vulnerable to User Interface (UI) Misrepresentation of Critical Information via the ?url parameter, which was intended to allow displaying remote OpenAPI definitions. This functionality may pose a risk for users who host their own SwaggerUI instances. In particular, including remote OpenAPI definitions opens a vector for phishing attacks by abusing the trusted names/domains of self-hosted instances.

Remediation

A fix was pushed into the master branch but not yet published.

References