laserdisc-io/tamer

Vulnerabilities

3 via 8 paths

Dependencies

124

Source

GitHub

Find, fix and prevent vulnerabilities in your code.

Severity
  • 3
Status
  • 3
  • 0
  • 0

medium severity

Unsafe Dependency Resolution

  • Vulnerable module: com.beust:jcommander
  • Introduced through: software.amazon.awssdk:netty-nio-client@2.17.45

Detailed paths

  • Introduced through: laserdisc-io/tamer@laserdisc-io/tamer software.amazon.awssdk:netty-nio-client@2.17.45 com.typesafe.netty:netty-reactive-streams-http@2.0.5 org.testng:testng@7.0.0 com.beust:jcommander@1.72
  • Introduced through: laserdisc-io/tamer@laserdisc-io/tamer software.amazon.awssdk:netty-nio-client@2.17.45 com.typesafe.netty:netty-reactive-streams-http@2.0.5 org.reactivestreams:reactive-streams-tck@1.0.3 org.testng:testng@7.0.0 com.beust:jcommander@1.72
  • Introduced through: laserdisc-io/tamer@laserdisc-io/tamer software.amazon.awssdk:netty-nio-client@2.17.45 com.typesafe.netty:netty-reactive-streams-http@2.0.5 com.typesafe.netty:netty-reactive-streams@2.0.5 org.testng:testng@7.0.0 com.beust:jcommander@1.72
  • Introduced through: laserdisc-io/tamer@laserdisc-io/tamer software.amazon.awssdk:netty-nio-client@2.17.45 com.typesafe.netty:netty-reactive-streams-http@2.0.5 com.typesafe.netty:netty-reactive-streams@2.0.5 org.reactivestreams:reactive-streams-tck@1.0.3 org.testng:testng@7.0.0 com.beust:jcommander@1.72

Overview

com.beust:jcommander is a Command line parsing framework for Java.

Affected versions of this package are vulnerable to Unsafe Dependency Resolution due to resolving dependencies over an insecure channel (http).

If the build occurred over an insecure connection, a malicious user could have perform a Man-in-the-Middle attack during the build and alter the build artifacts that were produced. In the case that any of these artifacts were compromised, any developers using them could be vulnerable.

Note: In order to validate that this artifact was not compromised, the maintainer would need to confirm that all of the artifacts published to the registry were not altered. Until this happens, we can not guarantee that this artifact was not compromised even though the probability that this happened is low.

We have chosen to alert on this issue when maintainers either decided to issue CVEs themselves, or in cases when maintainers decided against performing audits on their build to verify they had not been compromised.

Remediation

Upgrade com.beust:jcommander to version 1.75 or higher.

References

medium severity

Improper Certificate Validation

  • Vulnerable module: io.netty:netty-handler
  • Introduced through: software.amazon.awssdk:netty-nio-client@2.17.45

Detailed paths

  • Introduced through: laserdisc-io/tamer@laserdisc-io/tamer software.amazon.awssdk:netty-nio-client@2.17.45 io.netty:netty-handler@5.0.0.Alpha2
  • Introduced through: laserdisc-io/tamer@laserdisc-io/tamer software.amazon.awssdk:netty-nio-client@2.17.45 io.netty:netty-codec-http2@5.0.0.Alpha2 io.netty:netty-handler@5.0.0.Alpha2
  • Introduced through: laserdisc-io/tamer@laserdisc-io/tamer software.amazon.awssdk:netty-nio-client@2.17.45 com.typesafe.netty:netty-reactive-streams-http@2.0.5 com.typesafe.netty:netty-reactive-streams@2.0.5 io.netty:netty-handler@5.0.0.Alpha2

Overview

io.netty:netty-handler is a library that provides an asynchronous event-driven network application framework and tools for rapid development of maintainable high performance and high scalability protocol servers and clients. In other words, Netty is a NIO client server framework which enables quick and easy development of network applications such as protocol servers and clients. It greatly simplifies and streamlines network programming such as TCP and UDP socket server.

Affected versions of this package are vulnerable to Improper Certificate Validation. Certificate hostname validation is disabled by default in Netty 4.1.x which makes it potentially susceptible to Man-in-the-Middle attacks.

Remediation

There is no fixed version for io.netty:netty-handler.

References

medium severity
new

Timing Attack

  • Vulnerable module: org.apache.kafka:kafka-clients
  • Introduced through: org.apache.kafka:kafka-clients@2.7.0

Detailed paths

  • Introduced through: laserdisc-io/tamer@laserdisc-io/tamer org.apache.kafka:kafka-clients@2.7.0
    Remediation: Upgrade to org.apache.kafka:kafka-clients@2.8.1.

Overview

org.apache.kafka:kafka-clients is a streaming platform that can publish and subscribe to streams of records, store streams of records in a fault-tolerant durable way, and process streams of records as they occur.

Affected versions of this package are vulnerable to Timing Attack. Some components in Apache Kafka use Arrays.equals to validate a password or key, which is vulnerable to brute force attacks by malicious users.

Remediation

Upgrade org.apache.kafka:kafka-clients to version 2.8.1 or higher.

References