Vulnerabilities

1 via 2 paths

Dependencies

85

Source

GitHub

Find, fix and prevent vulnerabilities in your code.

Severity
  • 1
Status
  • 1
  • 0
  • 0

medium severity
new

Interpretation Conflict

  • Vulnerable module: crass
  • Introduced through: active_attr@0.17.2

Detailed paths

  • Introduced through: NREL/api-umbrella@NREL/api-umbrella › active_attr@0.17.2 › actionpack@8.1.4 › rails-html-sanitizer@1.7.1 › loofah@2.25.2 › crass@1.0.7
    Remediation: Upgrade to active_attr@0.17.2.
  • Introduced through: NREL/api-umbrella@NREL/api-umbrella › active_attr@0.17.2 › actionpack@8.1.4 › actionview@8.1.4 › rails-html-sanitizer@1.7.1 › loofah@2.25.2 › crass@1.0.7
    Remediation: Upgrade to active_attr@0.17.2.

Overview

Affected versions of this package are vulnerable to Interpretation Conflict in the tokenizer process. An attacker can inject arbitrary CSS declarations, style rules, or at-rules by crafting malicious CSS input that exploits incorrect tokenization of bad URLs, potentially bypassing sanitizers and leading to UI redress, loading of external resources, or CSS-based data exfiltration.

Remediation

Upgrade crass to version 1.0.8 or higher.

References