Vulnerabilities

83 via 237 paths

Dependencies

169

Source

Group 6 Copy Created with Sketch. Docker

Target OS

debian:11
Test your Docker Hub image against our market leading vulnerability database Sign up for free
Severity
  • 1
  • 82
Status
  • 83
  • 0
  • 0

high severity

Cleartext Transmission of Sensitive Information

  • Vulnerable module: curl
  • Introduced through: curl@7.74.0-1.3+deb11u3 and curl/libcurl4@7.74.0-1.3+deb11u3

Detailed paths

  • Introduced through: php@latest curl@7.74.0-1.3+deb11u3
  • Introduced through: php@latest curl/libcurl4@7.74.0-1.3+deb11u3

NVD Description

Note: Versions mentioned in the description apply to the upstream curl package.

In curl before 7.86.0, the HSTS check could be bypassed to trick it into staying with HTTP. Using its HSTS support, curl can be instructed to use HTTPS directly (instead of using an insecure cleartext HTTP step) even when HTTP is provided in the URL. This mechanism could be bypassed if the host name in the given URL uses IDN characters that get replaced with ASCII counterparts as part of the IDN conversion, e.g., using the character UTF-8 U+3002 (IDEOGRAPHIC FULL STOP) instead of the common ASCII full stop of U+002E (.). The earliest affected version is 7.77.0 2021-05-26.

Remediation

There is no fixed version for Debian:11 curl.

References

low severity

Out-of-bounds Read

  • Vulnerable module: db5.3/libdb5.3
  • Introduced through: db5.3/libdb5.3@5.3.28+dfsg1-0.8

Detailed paths

  • Introduced through: php@latest db5.3/libdb5.3@5.3.28+dfsg1-0.8

NVD Description

Note: Versions mentioned in the description apply to the upstream db5.3 package.

SQLite3 from 3.6.0 to and including 3.27.2 is vulnerable to heap out-of-bound read in the rtreenode() function when handling invalid rtree tables.

Remediation

There is no fixed version for Debian:11 db5.3.

References

low severity

Out-of-Bounds

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.31-13+deb11u5, glibc/libc-dev-bin@2.31-13+deb11u5 and others

Detailed paths

  • Introduced through: php@latest glibc/libc-bin@2.31-13+deb11u5
  • Introduced through: php@latest glibc/libc-dev-bin@2.31-13+deb11u5
  • Introduced through: php@latest glibc/libc6@2.31-13+deb11u5
  • Introduced through: php@latest glibc/libc6-dev@2.31-13+deb11u5

NVD Description

Note: Versions mentioned in the description apply to the upstream glibc package.

** DISPUTED ** GNU Libc current is affected by: Mitigation bypass. The impact is: Attacker may bypass stack guard protection. The component is: nptl. The attack vector is: Exploit stack buffer overflow vulnerability and use this bypass vulnerability to bypass stack guard. NOTE: Upstream comments indicate "this is being treated as a non-security bug and no real threat."

Remediation

There is no fixed version for Debian:11 glibc.

References

low severity

Out-of-bounds Write

  • Vulnerable module: re2c
  • Introduced through: re2c@2.0.3-1

Detailed paths

  • Introduced through: php@latest re2c@2.0.3-1

NVD Description

Note: Versions mentioned in the description apply to the upstream re2c package.

A stack overflow re2c 2.2 exists due to infinite recursion issues in src/dfa/dead_rules.cc.

Remediation

There is no fixed version for Debian:11 re2c.

References

low severity

CVE-2005-2541

  • Vulnerable module: tar
  • Introduced through: tar@1.34+dfsg-1

Detailed paths

  • Introduced through: php@latest tar@1.34+dfsg-1

NVD Description

Note: Versions mentioned in the description apply to the upstream tar package.

Tar 1.15.1 does not properly warn the user when extracting setuid or setgid files, which may allow local users or remote attackers to gain privileges.

Remediation

There is no fixed version for Debian:11 tar.

References

low severity

Out-of-bounds Read

  • Vulnerable module: libtasn1-6
  • Introduced through: libtasn1-6@4.16.0-2

Detailed paths

  • Introduced through: php@latest libtasn1-6@4.16.0-2

NVD Description

Note: Versions mentioned in the description apply to the upstream libtasn1-6 package.

GNU Libtasn1 before 4.19.0 has an ETYPE_OK off-by-one array size check that affects asn1_encode_simple_der.

Remediation

There is no fixed version for Debian:11 libtasn1-6.

References

low severity

CVE-2019-1010023

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.31-13+deb11u5, glibc/libc-dev-bin@2.31-13+deb11u5 and others

Detailed paths

  • Introduced through: php@latest glibc/libc-bin@2.31-13+deb11u5
  • Introduced through: php@latest glibc/libc-dev-bin@2.31-13+deb11u5
  • Introduced through: php@latest glibc/libc6@2.31-13+deb11u5
  • Introduced through: php@latest glibc/libc6-dev@2.31-13+deb11u5

NVD Description

Note: Versions mentioned in the description apply to the upstream glibc package.

** DISPUTED ** GNU Libc current is affected by: Re-mapping current loaded library with malicious ELF file. The impact is: In worst case attacker may evaluate privileges. The component is: libld. The attack vector is: Attacker sends 2 ELF files to victim and asks to run ldd on it. ldd execute code. NOTE: Upstream comments indicate "this is being treated as a non-security bug and no real threat."

Remediation

There is no fixed version for Debian:11 glibc.

References

low severity

Out-of-bounds Write

  • Vulnerable module: ncurses/libtinfo6
  • Introduced through: ncurses/libtinfo6@6.2+20201114-2, ncurses/ncurses-base@6.2+20201114-2 and others

Detailed paths

  • Introduced through: php@latest ncurses/libtinfo6@6.2+20201114-2
  • Introduced through: php@latest ncurses/ncurses-base@6.2+20201114-2
  • Introduced through: php@latest ncurses/ncurses-bin@6.2+20201114-2

NVD Description

Note: Versions mentioned in the description apply to the upstream ncurses package.

An issue was discovered in ncurses through v6.2-1. _nc_captoinfo in captoinfo.c has a heap-based buffer overflow.

Remediation

There is no fixed version for Debian:11 ncurses.

References

low severity

Integer Overflow or Wraparound

  • Vulnerable module: binutils
  • Introduced through: binutils@2.35.2-2, binutils/binutils-common@2.35.2-2 and others

Detailed paths

  • Introduced through: php@latest binutils@2.35.2-2
  • Introduced through: php@latest binutils/binutils-common@2.35.2-2
  • Introduced through: php@latest binutils/binutils-x86-64-linux-gnu@2.35.2-2
  • Introduced through: php@latest binutils/libbinutils@2.35.2-2
  • Introduced through: php@latest binutils/libctf-nobfd0@2.35.2-2
  • Introduced through: php@latest binutils/libctf0@2.35.2-2

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

The get_count function in cplus-dem.c in GNU libiberty, as distributed in GNU Binutils 2.31, allows remote attackers to cause a denial of service (malloc called with the result of an integer-overflowing calculation) or possibly have unspecified other impact via a crafted string, as demonstrated by c++filt.

Remediation

There is no fixed version for Debian:11 binutils.

References

low severity

Out-of-bounds Write

  • Vulnerable module: binutils
  • Introduced through: binutils@2.35.2-2, binutils/binutils-common@2.35.2-2 and others

Detailed paths

  • Introduced through: php@latest binutils@2.35.2-2
  • Introduced through: php@latest binutils/binutils-common@2.35.2-2
  • Introduced through: php@latest binutils/binutils-x86-64-linux-gnu@2.35.2-2
  • Introduced through: php@latest binutils/libbinutils@2.35.2-2
  • Introduced through: php@latest binutils/libctf-nobfd0@2.35.2-2
  • Introduced through: php@latest binutils/libctf0@2.35.2-2

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

stab_xcoff_builtin_type in stabs.c in GNU Binutils through 2.37 allows attackers to cause a denial of service (heap-based buffer overflow) or possibly have unspecified other impact, as demonstrated by an out-of-bounds write. NOTE: this issue exists because of an incorrect fix for CVE-2018-12699.

Remediation

There is no fixed version for Debian:11 binutils.

References

low severity

Out-of-bounds Read

  • Vulnerable module: e2fsprogs
  • Introduced through: e2fsprogs@1.46.2-2, e2fsprogs/libcom-err2@1.46.2-2 and others

Detailed paths

  • Introduced through: php@latest e2fsprogs@1.46.2-2
  • Introduced through: php@latest e2fsprogs/libcom-err2@1.46.2-2
  • Introduced through: php@latest e2fsprogs/libext2fs2@1.46.2-2
  • Introduced through: php@latest e2fsprogs/libss2@1.46.2-2
  • Introduced through: php@latest e2fsprogs/logsave@1.46.2-2

NVD Description

Note: Versions mentioned in the description apply to the upstream e2fsprogs package.

An out-of-bounds read/write vulnerability was found in e2fsprogs 1.46.5. This issue leads to a segmentation fault and possibly arbitrary code execution via a specially crafted filesystem.

Remediation

There is no fixed version for Debian:11 e2fsprogs.

References

low severity

Out-of-Bounds

  • Vulnerable module: pcre3/libpcre3
  • Introduced through: pcre3/libpcre3@2:8.39-13

Detailed paths

  • Introduced through: php@latest pcre3/libpcre3@2:8.39-13

NVD Description

Note: Versions mentioned in the description apply to the upstream pcre3 package.

Stack-based buffer overflow in the pcre32_copy_substring function in pcre_get.c in libpcre1 in PCRE 8.40 allows remote attackers to cause a denial of service (WRITE of size 4) or possibly have unspecified other impact via a crafted file.

Remediation

There is no fixed version for Debian:11 pcre3.

References

low severity

Out-of-Bounds

  • Vulnerable module: pcre3/libpcre3
  • Introduced through: pcre3/libpcre3@2:8.39-13

Detailed paths

  • Introduced through: php@latest pcre3/libpcre3@2:8.39-13

NVD Description

Note: Versions mentioned in the description apply to the upstream pcre3 package.

Stack-based buffer overflow in the pcre32_copy_substring function in pcre_get.c in libpcre1 in PCRE 8.40 allows remote attackers to cause a denial of service (WRITE of size 268) or possibly have unspecified other impact via a crafted file.

Remediation

There is no fixed version for Debian:11 pcre3.

References

low severity

Improper Verification of Cryptographic Signature

  • Vulnerable module: perl
  • Introduced through: perl@5.32.1-4+deb11u2, perl/libperl5.32@5.32.1-4+deb11u2 and others

Detailed paths

  • Introduced through: php@latest perl@5.32.1-4+deb11u2
  • Introduced through: php@latest perl/libperl5.32@5.32.1-4+deb11u2
  • Introduced through: php@latest perl/perl-base@5.32.1-4+deb11u2
  • Introduced through: php@latest perl/perl-modules-5.32@5.32.1-4+deb11u2

NVD Description

Note: Versions mentioned in the description apply to the upstream perl package.

CPAN 2.28 allows Signature Verification Bypass.

Remediation

There is no fixed version for Debian:11 perl.

References

low severity

Incorrect Permission Assignment for Critical Resource

  • Vulnerable module: shadow/login
  • Introduced through: shadow/login@1:4.8.1-1 and shadow/passwd@1:4.8.1-1

Detailed paths

  • Introduced through: php@latest shadow/login@1:4.8.1-1
  • Introduced through: php@latest shadow/passwd@1:4.8.1-1

NVD Description

Note: Versions mentioned in the description apply to the upstream shadow package.

shadow 4.8, in certain circumstances affecting at least Gentoo, Arch Linux, and Void Linux, allows local users to obtain root access because setuid programs are misconfigured. Specifically, this affects shadow 4.8 when compiled using --with-libpam but without explicitly passing --disable-account-tools-setuid, and without a PAM configuration suitable for use with setuid account management tools. This combination leads to account management tools (groupadd, groupdel, groupmod, useradd, userdel, usermod) that can easily be used by unprivileged local users to escalate privileges to root in multiple ways. This issue became much more relevant in approximately December 2019 when an unrelated bug was fixed (i.e., the chmod calls to suidusbins were fixed in the upstream Makefile which is now included in the release version 4.8).

Remediation

There is no fixed version for Debian:11 shadow.

References

low severity

Allocation of Resources Without Limits or Throttling

  • Vulnerable module: binutils
  • Introduced through: binutils@2.35.2-2, binutils/binutils-common@2.35.2-2 and others

Detailed paths

  • Introduced through: php@latest binutils@2.35.2-2
  • Introduced through: php@latest binutils/binutils-common@2.35.2-2
  • Introduced through: php@latest binutils/binutils-x86-64-linux-gnu@2.35.2-2
  • Introduced through: php@latest binutils/libbinutils@2.35.2-2
  • Introduced through: php@latest binutils/libctf-nobfd0@2.35.2-2
  • Introduced through: php@latest binutils/libctf0@2.35.2-2

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

remember_Ktype in cplus-dem.c in GNU libiberty, as distributed in GNU Binutils 2.30, allows attackers to trigger excessive memory consumption (aka OOM). This can occur during execution of cxxfilt.

Remediation

There is no fixed version for Debian:11 binutils.

References

low severity

Out-of-Bounds

  • Vulnerable module: binutils
  • Introduced through: binutils@2.35.2-2, binutils/binutils-common@2.35.2-2 and others

Detailed paths

  • Introduced through: php@latest binutils@2.35.2-2
  • Introduced through: php@latest binutils/binutils-common@2.35.2-2
  • Introduced through: php@latest binutils/binutils-x86-64-linux-gnu@2.35.2-2
  • Introduced through: php@latest binutils/libbinutils@2.35.2-2
  • Introduced through: php@latest binutils/libctf-nobfd0@2.35.2-2
  • Introduced through: php@latest binutils/libctf0@2.35.2-2

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

Heap/stack buffer overflow in the dlang_lname function in d-demangle.c in libiberty allows attackers to potentially cause a denial of service (segmentation fault and crash) via a crafted mangled symbol.

Remediation

There is no fixed version for Debian:11 binutils.

References

low severity

Uncontrolled Recursion

  • Vulnerable module: binutils
  • Introduced through: binutils@2.35.2-2, binutils/binutils-common@2.35.2-2 and others

Detailed paths

  • Introduced through: php@latest binutils@2.35.2-2
  • Introduced through: php@latest binutils/binutils-common@2.35.2-2
  • Introduced through: php@latest binutils/binutils-x86-64-linux-gnu@2.35.2-2
  • Introduced through: php@latest binutils/libbinutils@2.35.2-2
  • Introduced through: php@latest binutils/libctf-nobfd0@2.35.2-2
  • Introduced through: php@latest binutils/libctf0@2.35.2-2

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

A flaw was discovered in GNU libiberty within demangle_path() in rust-demangle.c, as distributed in GNU Binutils version 2.36. A crafted symbol can cause stack memory to be exhausted leading to a crash.

Remediation

There is no fixed version for Debian:11 binutils.

References

low severity

Uncontrolled Recursion

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.31-13+deb11u5, glibc/libc-dev-bin@2.31-13+deb11u5 and others

Detailed paths

  • Introduced through: php@latest glibc/libc-bin@2.31-13+deb11u5
  • Introduced through: php@latest glibc/libc-dev-bin@2.31-13+deb11u5
  • Introduced through: php@latest glibc/libc6@2.31-13+deb11u5
  • Introduced through: php@latest glibc/libc6-dev@2.31-13+deb11u5

NVD Description

Note: Versions mentioned in the description apply to the upstream glibc package.

** DISPUTED ** In the GNU C Library (aka glibc or libc6) through 2.29, check_dst_limits_calc_pos_1 in posix/regexec.c has Uncontrolled Recursion, as demonstrated by '(|)(\1\1)*' in grep, a different issue than CVE-2018-20796. NOTE: the software maintainer disputes that this is a vulnerability because the behavior occurs only with a crafted pattern.

Remediation

There is no fixed version for Debian:11 glibc.

References

low severity

Uncontrolled Recursion

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.31-13+deb11u5, glibc/libc-dev-bin@2.31-13+deb11u5 and others

Detailed paths

  • Introduced through: php@latest glibc/libc-bin@2.31-13+deb11u5
  • Introduced through: php@latest glibc/libc-dev-bin@2.31-13+deb11u5
  • Introduced through: php@latest glibc/libc6@2.31-13+deb11u5
  • Introduced through: php@latest glibc/libc6-dev@2.31-13+deb11u5

NVD Description

Note: Versions mentioned in the description apply to the upstream glibc package.

In the GNU C Library (aka glibc or libc6) through 2.29, check_dst_limits_calc_pos_1 in posix/regexec.c has Uncontrolled Recursion, as demonstrated by '(\227|)(\1\1|t1|\\2537)+' in grep.

Remediation

There is no fixed version for Debian:11 glibc.

References

low severity

Integer Overflow or Wraparound

  • Vulnerable module: krb5/libgssapi-krb5-2
  • Introduced through: krb5/libgssapi-krb5-2@1.18.3-6+deb11u2, krb5/libk5crypto3@1.18.3-6+deb11u2 and others

Detailed paths

  • Introduced through: php@latest krb5/libgssapi-krb5-2@1.18.3-6+deb11u2
  • Introduced through: php@latest krb5/libk5crypto3@1.18.3-6+deb11u2
  • Introduced through: php@latest krb5/libkrb5-3@1.18.3-6+deb11u2
  • Introduced through: php@latest krb5/libkrb5support0@1.18.3-6+deb11u2

NVD Description

Note: Versions mentioned in the description apply to the upstream krb5 package.

An issue was discovered in MIT Kerberos 5 (aka krb5) through 1.16. There is a variable "dbentry->n_key_data" in kadmin/dbutil/dump.c that can store 16-bit data but unknowingly the developer has assigned a "u4" variable to it, which is for 32-bit data. An attacker can use this vulnerability to affect other artifacts of the database as we know that a Kerberos database dump file contains trusted data.

Remediation

There is no fixed version for Debian:11 krb5.

References

low severity

Information Exposure

  • Vulnerable module: libgcrypt20
  • Introduced through: libgcrypt20@1.8.7-6

Detailed paths

  • Introduced through: php@latest libgcrypt20@1.8.7-6

NVD Description

Note: Versions mentioned in the description apply to the upstream libgcrypt20 package.

Libgcrypt before 1.8.8 and 1.9.x before 1.9.3 mishandles ElGamal encryption because it lacks exponent blinding to address a side-channel attack against mpi_powm, and the window size is not chosen appropriately. This, for example, affects use of ElGamal in OpenPGP.

Remediation

There is no fixed version for Debian:11 libgcrypt20.

References

low severity

Use of a Broken or Risky Cryptographic Algorithm

  • Vulnerable module: libgcrypt20
  • Introduced through: libgcrypt20@1.8.7-6

Detailed paths

  • Introduced through: php@latest libgcrypt20@1.8.7-6

NVD Description

Note: Versions mentioned in the description apply to the upstream libgcrypt20 package.

cipher/elgamal.c in Libgcrypt through 1.8.2, when used to encrypt messages directly, improperly encodes plaintexts, which allows attackers to obtain sensitive information by reading ciphertext data (i.e., it does not have semantic security in face of a ciphertext-only attack). The Decisional Diffie-Hellman (DDH) assumption does not hold for Libgcrypt's ElGamal implementation.

Remediation

There is no fixed version for Debian:11 libgcrypt20.

References

low severity

Out-of-Bounds

  • Vulnerable module: openldap/libldap-2.4-2
  • Introduced through: openldap/libldap-2.4-2@2.4.57+dfsg-3+deb11u1

Detailed paths

  • Introduced through: php@latest openldap/libldap-2.4-2@2.4.57+dfsg-3+deb11u1

NVD Description

Note: Versions mentioned in the description apply to the upstream openldap package.

contrib/slapd-modules/nops/nops.c in OpenLDAP through 2.4.45, when both the nops module and the memberof overlay are enabled, attempts to free a buffer that was allocated on the stack, which allows remote attackers to cause a denial of service (slapd crash) via a member MODDN operation.

Remediation

There is no fixed version for Debian:11 openldap.

References

low severity

Double Free

  • Vulnerable module: patch
  • Introduced through: patch@2.7.6-7

Detailed paths

  • Introduced through: php@latest patch@2.7.6-7

NVD Description

Note: Versions mentioned in the description apply to the upstream patch package.

A double free exists in the another_hunk function in pch.c in GNU patch through 2.7.6.

Remediation

There is no fixed version for Debian:11 patch.

References

low severity

NULL Pointer Dereference

  • Vulnerable module: patch
  • Introduced through: patch@2.7.6-7

Detailed paths

  • Introduced through: php@latest patch@2.7.6-7

NVD Description

Note: Versions mentioned in the description apply to the upstream patch package.

An issue was discovered in GNU patch through 2.7.6. There is a segmentation fault, associated with a NULL pointer dereference, leading to a denial of service in the intuit_diff_type function in pch.c, aka a "mangled rename" issue.

Remediation

There is no fixed version for Debian:11 patch.

References

low severity

Out-of-bounds Read

  • Vulnerable module: pcre3/libpcre3
  • Introduced through: pcre3/libpcre3@2:8.39-13

Detailed paths

  • Introduced through: php@latest pcre3/libpcre3@2:8.39-13

NVD Description

Note: Versions mentioned in the description apply to the upstream pcre3 package.

libpcre in PCRE before 8.43 allows a subject buffer over-read in JIT when UTF is disabled, and \X or \R has more than one fixed quantifier, a related issue to CVE-2019-20454.

Remediation

There is no fixed version for Debian:11 pcre3.

References

low severity

Uncontrolled Recursion

  • Vulnerable module: pcre3/libpcre3
  • Introduced through: pcre3/libpcre3@2:8.39-13

Detailed paths

  • Introduced through: php@latest pcre3/libpcre3@2:8.39-13

NVD Description

Note: Versions mentioned in the description apply to the upstream pcre3 package.

In PCRE 8.41, the OP_KETRMAX feature in the match function in pcre_exec.c allows stack exhaustion (uncontrolled recursion) when processing a crafted regular expression.

Remediation

There is no fixed version for Debian:11 pcre3.

References

low severity

Link Following

  • Vulnerable module: perl
  • Introduced through: perl@5.32.1-4+deb11u2, perl/libperl5.32@5.32.1-4+deb11u2 and others

Detailed paths

  • Introduced through: php@latest perl@5.32.1-4+deb11u2
  • Introduced through: php@latest perl/libperl5.32@5.32.1-4+deb11u2
  • Introduced through: php@latest perl/perl-base@5.32.1-4+deb11u2
  • Introduced through: php@latest perl/perl-modules-5.32@5.32.1-4+deb11u2

NVD Description

Note: Versions mentioned in the description apply to the upstream perl package.

_is_safe in the File::Temp module for Perl does not properly handle symlinks.

Remediation

There is no fixed version for Debian:11 perl.

References

low severity

CVE-2021-36690

  • Vulnerable module: sqlite3/libsqlite3-0
  • Introduced through: sqlite3/libsqlite3-0@3.34.1-3

Detailed paths

  • Introduced through: php@latest sqlite3/libsqlite3-0@3.34.1-3

NVD Description

Note: Versions mentioned in the description apply to the upstream sqlite3 package.

** DISPUTED ** A segmentation fault can occur in the sqlite3.exe command-line component of SQLite 3.36.0 via the idxGetTableInfo function when there is a crafted SQL query. NOTE: the vendor disputes the relevance of this report because a sqlite3.exe user already has full privileges (e.g., is intentionally allowed to execute commands). This report does NOT imply any problem in the SQLite library.

Remediation

There is no fixed version for Debian:11 sqlite3.

References

low severity

Improper Validation of Array Index

  • Vulnerable module: sqlite3/libsqlite3-0
  • Introduced through: sqlite3/libsqlite3-0@3.34.1-3

Detailed paths

  • Introduced through: php@latest sqlite3/libsqlite3-0@3.34.1-3

NVD Description

Note: Versions mentioned in the description apply to the upstream sqlite3 package.

SQLite 1.0.12 through 3.39.x before 3.39.2 sometimes allows an array-bounds overflow if billions of bytes are used in a string argument to a C API.

Remediation

There is no fixed version for Debian:11 sqlite3.

References

low severity

CVE-2008-1687

  • Vulnerable module: m4
  • Introduced through: m4@1.4.18-5

Detailed paths

  • Introduced through: php@latest m4@1.4.18-5

NVD Description

Note: Versions mentioned in the description apply to the upstream m4 package.

The (1) maketemp and (2) mkstemp builtin functions in GNU m4 before 1.4.11 do not quote their output when a file is created, which might allow context-dependent attackers to trigger a macro expansion, leading to unspecified use of an incorrect filename.

Remediation

There is no fixed version for Debian:11 m4.

References

low severity

CVE-2008-1688

  • Vulnerable module: m4
  • Introduced through: m4@1.4.18-5

Detailed paths

  • Introduced through: php@latest m4@1.4.18-5

NVD Description

Note: Versions mentioned in the description apply to the upstream m4 package.

Unspecified vulnerability in GNU m4 before 1.4.11 might allow context-dependent attackers to execute arbitrary code, related to improper handling of filenames specified with the -F option. NOTE: it is not clear when this issue crosses privilege boundaries.

Remediation

There is no fixed version for Debian:11 m4.

References

low severity

Out-of-bounds Write

  • Vulnerable module: binutils
  • Introduced through: binutils@2.35.2-2, binutils/binutils-common@2.35.2-2 and others

Detailed paths

  • Introduced through: php@latest binutils@2.35.2-2
  • Introduced through: php@latest binutils/binutils-common@2.35.2-2
  • Introduced through: php@latest binutils/binutils-x86-64-linux-gnu@2.35.2-2
  • Introduced through: php@latest binutils/libbinutils@2.35.2-2
  • Introduced through: php@latest binutils/libctf-nobfd0@2.35.2-2
  • Introduced through: php@latest binutils/libctf0@2.35.2-2

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

An out of bounds flaw was found in GNU binutils objdump utility version 2.36. An attacker could use this flaw and pass a large section to avr_elf32_load_records_from_section() probably resulting in a crash or in some cases memory corruption. The highest threat from this vulnerability is to integrity as well as system availability.

Remediation

There is no fixed version for Debian:11 binutils.

References

low severity

Out-of-bounds Read

  • Vulnerable module: ncurses/libtinfo6
  • Introduced through: ncurses/libtinfo6@6.2+20201114-2, ncurses/ncurses-base@6.2+20201114-2 and others

Detailed paths

  • Introduced through: php@latest ncurses/libtinfo6@6.2+20201114-2
  • Introduced through: php@latest ncurses/ncurses-base@6.2+20201114-2
  • Introduced through: php@latest ncurses/ncurses-bin@6.2+20201114-2

NVD Description

Note: Versions mentioned in the description apply to the upstream ncurses package.

ncurses 6.3 before patch 20220416 has an out-of-bounds read and segmentation violation in convert_strings in tinfo/read_entry.c in the terminfo library.

Remediation

There is no fixed version for Debian:11 ncurses.

References

low severity

Improper Input Validation

  • Vulnerable module: binutils
  • Introduced through: binutils@2.35.2-2, binutils/binutils-common@2.35.2-2 and others

Detailed paths

  • Introduced through: php@latest binutils@2.35.2-2
  • Introduced through: php@latest binutils/binutils-common@2.35.2-2
  • Introduced through: php@latest binutils/binutils-x86-64-linux-gnu@2.35.2-2
  • Introduced through: php@latest binutils/libbinutils@2.35.2-2
  • Introduced through: php@latest binutils/libctf-nobfd0@2.35.2-2
  • Introduced through: php@latest binutils/libctf0@2.35.2-2

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

There's a flaw in the BFD library of binutils in versions before 2.36. An attacker who supplies a crafted file to an application linked with BFD, and using the DWARF functionality, could cause an impact to system availability by way of excessive memory consumption.

Remediation

There is no fixed version for Debian:11 binutils.

References

low severity

Out-of-bounds Read

  • Vulnerable module: binutils
  • Introduced through: binutils@2.35.2-2, binutils/binutils-common@2.35.2-2 and others

Detailed paths

  • Introduced through: php@latest binutils@2.35.2-2
  • Introduced through: php@latest binutils/binutils-common@2.35.2-2
  • Introduced through: php@latest binutils/binutils-x86-64-linux-gnu@2.35.2-2
  • Introduced through: php@latest binutils/libbinutils@2.35.2-2
  • Introduced through: php@latest binutils/libctf-nobfd0@2.35.2-2
  • Introduced through: php@latest binutils/libctf0@2.35.2-2

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

A heap-based buffer over-read exists in the function d_expression_1 in cp-demangle.c in GNU libiberty, as distributed in GNU Binutils 2.31.1. A crafted input can cause segmentation faults, leading to denial-of-service, as demonstrated by c++filt.

Remediation

There is no fixed version for Debian:11 binutils.

References

low severity

Improper Input Validation

  • Vulnerable module: coreutils/coreutils
  • Introduced through: coreutils/coreutils@8.32-4+b1

Detailed paths

  • Introduced through: php@latest coreutils/coreutils@8.32-4+b1

NVD Description

Note: Versions mentioned in the description apply to the upstream coreutils package.

chroot in GNU coreutils, when used with --userspec, allows local users to escape to the parent session via a crafted TIOCSTI ioctl call, which pushes characters to the terminal's input buffer.

Remediation

There is no fixed version for Debian:11 coreutils.

References

low severity

Improper Handling of Exceptional Conditions

  • Vulnerable module: curl
  • Introduced through: curl@7.74.0-1.3+deb11u3 and curl/libcurl4@7.74.0-1.3+deb11u3

Detailed paths

  • Introduced through: php@latest curl@7.74.0-1.3+deb11u3
  • Introduced through: php@latest curl/libcurl4@7.74.0-1.3+deb11u3

NVD Description

Note: Versions mentioned in the description apply to the upstream curl package.

When curl is instructed to download content using the metalink feature, thecontents is verified against a hash provided in the metalink XML file.The metalink XML file points out to the client how to get the same contentfrom a set of different URLs, potentially hosted by different servers and theclient can then download the file from one or several of them. In a serial orparallel manner.If one of the servers hosting the contents has been breached and the contentsof the specific file on that server is replaced with a modified payload, curlshould detect this when the hash of the file mismatches after a completeddownload. It should remove the contents and instead try getting the contentsfrom another URL. This is not done, and instead such a hash mismatch is onlymentioned in text and the potentially malicious content is kept in the file ondisk.

Remediation

There is no fixed version for Debian:11 curl.

References

low severity

Race Condition

  • Vulnerable module: binutils
  • Introduced through: binutils@2.35.2-2, binutils/binutils-common@2.35.2-2 and others

Detailed paths

  • Introduced through: php@latest binutils@2.35.2-2
  • Introduced through: php@latest binutils/binutils-common@2.35.2-2
  • Introduced through: php@latest binutils/binutils-x86-64-linux-gnu@2.35.2-2
  • Introduced through: php@latest binutils/libbinutils@2.35.2-2
  • Introduced through: php@latest binutils/libctf-nobfd0@2.35.2-2
  • Introduced through: php@latest binutils/libctf0@2.35.2-2

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

There is an open race window when writing output in the following utilities in GNU binutils version 2.35 and earlier:ar, objcopy, strip, ranlib. When these utilities are run as a privileged user (presumably as part of a script updating binaries across different users), an unprivileged user can trick these utilities into getting ownership of arbitrary files through a symlink.

Remediation

There is no fixed version for Debian:11 binutils.

References

low severity

Access Restriction Bypass

  • Vulnerable module: shadow/login
  • Introduced through: shadow/login@1:4.8.1-1 and shadow/passwd@1:4.8.1-1

Detailed paths

  • Introduced through: php@latest shadow/login@1:4.8.1-1
  • Introduced through: php@latest shadow/passwd@1:4.8.1-1

NVD Description

Note: Versions mentioned in the description apply to the upstream shadow package.

initscripts in rPath Linux 1 sets insecure permissions for the /var/log/btmp file, which allows local users to obtain sensitive information regarding authentication attempts. NOTE: because sshd detects the insecure permissions and does not log certain events, this also prevents sshd from logging failed authentication attempts by remote attackers.

Remediation

There is no fixed version for Debian:11 shadow.

References

low severity

Cross-site Scripting (XSS)

  • Vulnerable module: libxml2
  • Introduced through: libxml2@2.9.10+dfsg-6.7+deb11u3

Detailed paths

  • Introduced through: php@latest libxml2@2.9.10+dfsg-6.7+deb11u3

NVD Description

Note: Versions mentioned in the description apply to the upstream libxml2 package.

Possible cross-site scripting vulnerability in libxml after commit 960f0e2.

Remediation

There is no fixed version for Debian:11 libxml2.

References

low severity

Authentication Bypass

  • Vulnerable module: systemd/libsystemd0
  • Introduced through: systemd/libsystemd0@247.3-7+deb11u1 and systemd/libudev1@247.3-7+deb11u1

Detailed paths

  • Introduced through: php@latest systemd/libsystemd0@247.3-7+deb11u1
  • Introduced through: php@latest systemd/libudev1@247.3-7+deb11u1

NVD Description

Note: Versions mentioned in the description apply to the upstream systemd package.

An exploitable denial-of-service vulnerability exists in Systemd 245. A specially crafted DHCP FORCERENEW packet can cause a server running the DHCP client to be vulnerable to a DHCP ACK spoofing attack. An attacker can forge a pair of FORCERENEW and DCHP ACK packets to reconfigure the server.

Remediation

There is no fixed version for Debian:11 systemd.

References

low severity

Allocation of Resources Without Limits or Throttling

  • Vulnerable module: binutils
  • Introduced through: binutils@2.35.2-2, binutils/binutils-common@2.35.2-2 and others

Detailed paths

  • Introduced through: php@latest binutils@2.35.2-2
  • Introduced through: php@latest binutils/binutils-common@2.35.2-2
  • Introduced through: php@latest binutils/binutils-x86-64-linux-gnu@2.35.2-2
  • Introduced through: php@latest binutils/libbinutils@2.35.2-2
  • Introduced through: php@latest binutils/libctf-nobfd0@2.35.2-2
  • Introduced through: php@latest binutils/libctf0@2.35.2-2

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

The C++ symbol demangler routine in cplus-dem.c in libiberty, as distributed in GNU Binutils 2.29, allows remote attackers to cause a denial of service (excessive memory allocation and application crash) via a crafted file, as demonstrated by a call from the Binary File Descriptor (BFD) library (aka libbfd).

Remediation

There is no fixed version for Debian:11 binutils.

References

low severity

Out-of-bounds Read

  • Vulnerable module: binutils
  • Introduced through: binutils@2.35.2-2, binutils/binutils-common@2.35.2-2 and others

Detailed paths

  • Introduced through: php@latest binutils@2.35.2-2
  • Introduced through: php@latest binutils/binutils-common@2.35.2-2
  • Introduced through: php@latest binutils/binutils-x86-64-linux-gnu@2.35.2-2
  • Introduced through: php@latest binutils/libbinutils@2.35.2-2
  • Introduced through: php@latest binutils/libctf-nobfd0@2.35.2-2
  • Introduced through: php@latest binutils/libctf0@2.35.2-2

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

GNU binutils gold gold v1.11-v1.16 (GNU binutils v2.21-v2.31.1) is affected by: Improper Input Validation, Signed/Unsigned Comparison, Out-of-bounds Read. The impact is: Denial of service. The component is: gold/fileread.cc:497, elfcpp/elfcpp_file.h:644. The attack vector is: An ELF file with an invalid e_shoff header field must be opened.

Remediation

There is no fixed version for Debian:11 binutils.

References

low severity

Out-of-bounds Write

  • Vulnerable module: binutils
  • Introduced through: binutils@2.35.2-2, binutils/binutils-common@2.35.2-2 and others

Detailed paths

  • Introduced through: php@latest binutils@2.35.2-2
  • Introduced through: php@latest binutils/binutils-common@2.35.2-2
  • Introduced through: php@latest binutils/binutils-x86-64-linux-gnu@2.35.2-2
  • Introduced through: php@latest binutils/libbinutils@2.35.2-2
  • Introduced through: php@latest binutils/libctf-nobfd0@2.35.2-2
  • Introduced through: php@latest binutils/libctf0@2.35.2-2

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

A flaw was found in GNU Binutils 2.35.1, where there is a heap-based buffer overflow in _bfd_elf_slurp_secondary_reloc_section in elf.c due to the number of symbols not calculated correctly. The highest threat from this vulnerability is to system availability.

Remediation

There is no fixed version for Debian:11 binutils.

References

low severity

Out-of-bounds Write

  • Vulnerable module: binutils
  • Introduced through: binutils@2.35.2-2, binutils/binutils-common@2.35.2-2 and others

Detailed paths

  • Introduced through: php@latest binutils@2.35.2-2
  • Introduced through: php@latest binutils/binutils-common@2.35.2-2
  • Introduced through: php@latest binutils/binutils-x86-64-linux-gnu@2.35.2-2
  • Introduced through: php@latest binutils/libbinutils@2.35.2-2
  • Introduced through: php@latest binutils/libctf-nobfd0@2.35.2-2
  • Introduced through: php@latest binutils/libctf0@2.35.2-2

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

In GNU Binutils before 2.40, there is a heap-buffer-overflow in the error function bfd_getl32 when called from the strip_main function in strip-new via a crafted file.

Remediation

There is no fixed version for Debian:11 binutils.

References

low severity

Out-of-bounds Write

  • Vulnerable module: binutils
  • Introduced through: binutils@2.35.2-2, binutils/binutils-common@2.35.2-2 and others

Detailed paths

  • Introduced through: php@latest binutils@2.35.2-2
  • Introduced through: php@latest binutils/binutils-common@2.35.2-2
  • Introduced through: php@latest binutils/binutils-x86-64-linux-gnu@2.35.2-2
  • Introduced through: php@latest binutils/libbinutils@2.35.2-2
  • Introduced through: php@latest binutils/libctf-nobfd0@2.35.2-2
  • Introduced through: php@latest binutils/libctf0@2.35.2-2

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

The demangle_template function in cplus-dem.c in GNU libiberty, as distributed in GNU Binutils 2.31.1, contains an integer overflow vulnerability (for "Create an array for saving the template argument values") that can trigger a heap-based buffer overflow, as demonstrated by nm.

Remediation

There is no fixed version for Debian:11 binutils.

References

low severity

Uncontrolled Recursion

  • Vulnerable module: binutils
  • Introduced through: binutils@2.35.2-2, binutils/binutils-common@2.35.2-2 and others

Detailed paths

  • Introduced through: php@latest binutils@2.35.2-2
  • Introduced through: php@latest binutils/binutils-common@2.35.2-2
  • Introduced through: php@latest binutils/binutils-x86-64-linux-gnu@2.35.2-2
  • Introduced through: php@latest binutils/libbinutils@2.35.2-2
  • Introduced through: php@latest binutils/libctf-nobfd0@2.35.2-2
  • Introduced through: php@latest binutils/libctf0@2.35.2-2

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

GCC v12.0 was discovered to contain an uncontrolled recursion via the component libiberty/rust-demangle.c. This vulnerability allows attackers to cause a Denial of Service (DoS) by consuming excessive CPU and memory resources.

Remediation

There is no fixed version for Debian:11 binutils.

References

low severity

Uncontrolled Recursion

  • Vulnerable module: binutils
  • Introduced through: binutils@2.35.2-2, binutils/binutils-common@2.35.2-2 and others

Detailed paths

  • Introduced through: php@latest binutils@2.35.2-2
  • Introduced through: php@latest binutils/binutils-common@2.35.2-2
  • Introduced through: php@latest binutils/binutils-x86-64-linux-gnu@2.35.2-2
  • Introduced through: php@latest binutils/libbinutils@2.35.2-2
  • Introduced through: php@latest binutils/libctf-nobfd0@2.35.2-2
  • Introduced through: php@latest binutils/libctf0@2.35.2-2

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

An issue was discovered in cplus-dem.c in GNU libiberty, as distributed in GNU Binutils 2.30. Stack Exhaustion occurs in the C++ demangling functions provided by libiberty, and there are recursive stack frames: demangle_template_value_parm, demangle_integral_value, and demangle_expression.

Remediation

There is no fixed version for Debian:11 binutils.

References

low severity

Use After Free

  • Vulnerable module: binutils
  • Introduced through: binutils@2.35.2-2, binutils/binutils-common@2.35.2-2 and others

Detailed paths

  • Introduced through: php@latest binutils@2.35.2-2
  • Introduced through: php@latest binutils/binutils-common@2.35.2-2
  • Introduced through: php@latest binutils/binutils-x86-64-linux-gnu@2.35.2-2
  • Introduced through: php@latest binutils/libbinutils@2.35.2-2
  • Introduced through: php@latest binutils/libctf-nobfd0@2.35.2-2
  • Introduced through: php@latest binutils/libctf0@2.35.2-2

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

In GNU Binutils 2.31.1, there is a use-after-free in the error function in elfcomm.c when called from the process_archive function in readelf.c via a crafted ELF file.

Remediation

There is no fixed version for Debian:11 binutils.

References

low severity

Release of Invalid Pointer or Reference

  • Vulnerable module: patch
  • Introduced through: patch@2.7.6-7

Detailed paths

  • Introduced through: php@latest patch@2.7.6-7

NVD Description

Note: Versions mentioned in the description apply to the upstream patch package.

An Invalid Pointer vulnerability exists in GNU patch 2.7 via the another_hunk function, which causes a Denial of Service.

Remediation

There is no fixed version for Debian:11 patch.

References

low severity

Out-of-Bounds

  • Vulnerable module: pcre3/libpcre3
  • Introduced through: pcre3/libpcre3@2:8.39-13

Detailed paths

  • Introduced through: php@latest pcre3/libpcre3@2:8.39-13

NVD Description

Note: Versions mentioned in the description apply to the upstream pcre3 package.

** DISPUTED ** In PCRE 8.41, after compiling, a pcretest load test PoC produces a crash overflow in the function match() in pcre_exec.c because of a self-recursive call. NOTE: third parties dispute the relevance of this report, noting that there are options that can be used to limit the amount of stack that is used.

Remediation

There is no fixed version for Debian:11 pcre3.

References

low severity

Uncontrolled Recursion

  • Vulnerable module: re2c
  • Introduced through: re2c@2.0.3-1

Detailed paths

  • Introduced through: php@latest re2c@2.0.3-1

NVD Description

Note: Versions mentioned in the description apply to the upstream re2c package.

re2c before 2.0 has uncontrolled recursion that causes stack consumption in find_fixed_tags.

Remediation

There is no fixed version for Debian:11 re2c.

References

low severity
new

Off-by-one Error

  • Vulnerable module: systemd/libsystemd0
  • Introduced through: systemd/libsystemd0@247.3-7+deb11u1 and systemd/libudev1@247.3-7+deb11u1

Detailed paths

  • Introduced through: php@latest systemd/libsystemd0@247.3-7+deb11u1
  • Introduced through: php@latest systemd/libudev1@247.3-7+deb11u1

NVD Description

Note: Versions mentioned in the description apply to the upstream systemd package.

An off-by-one Error issue was discovered in Systemd in format_timespan() function of time-util.c. An attacker could supply specific values for time and accuracy that leads to buffer overrun in format_timespan(), leading to a Denial of Service.

Remediation

There is no fixed version for Debian:11 systemd.

References

low severity

Information Exposure

  • Vulnerable module: util-linux
  • Introduced through: util-linux@2.36.1-8+deb11u1, util-linux/bsdutils@1:2.36.1-8+deb11u1 and others

Detailed paths

  • Introduced through: php@latest util-linux@2.36.1-8+deb11u1
  • Introduced through: php@latest util-linux/bsdutils@1:2.36.1-8+deb11u1
  • Introduced through: php@latest util-linux/libblkid1@2.36.1-8+deb11u1
  • Introduced through: php@latest util-linux/libmount1@2.36.1-8+deb11u1
  • Introduced through: php@latest util-linux/libsmartcols1@2.36.1-8+deb11u1
  • Introduced through: php@latest util-linux/libuuid1@2.36.1-8+deb11u1
  • Introduced through: php@latest util-linux/mount@2.36.1-8+deb11u1

NVD Description

Note: Versions mentioned in the description apply to the upstream util-linux package.

A flaw was found in the util-linux chfn and chsh utilities when compiled with Readline support. The Readline library uses an "INPUTRC" environment variable to get a path to the library config file. When the library cannot parse the specified file, it prints an error message containing data from the file. This flaw allows an unprivileged user to read root-owned files, potentially leading to privilege escalation. This flaw affects util-linux versions prior to 2.37.4.

Remediation

There is no fixed version for Debian:11 util-linux.

References

low severity

Use of a Broken or Risky Cryptographic Algorithm

  • Vulnerable module: openssl
  • Introduced through: openssl@1.1.1n-0+deb11u3 and openssl/libssl1.1@1.1.1n-0+deb11u3

Detailed paths

  • Introduced through: php@latest openssl@1.1.1n-0+deb11u3
  • Introduced through: php@latest openssl/libssl1.1@1.1.1n-0+deb11u3

NVD Description

Note: Versions mentioned in the description apply to the upstream openssl package.

The NIST SP 800-90A default statement of the Dual Elliptic Curve Deterministic Random Bit Generation (Dual_EC_DRBG) algorithm contains point Q constants with a possible relationship to certain "skeleton key" values, which might allow context-dependent attackers to defeat cryptographic protection mechanisms by leveraging knowledge of those values. NOTE: this is a preliminary CVE for Dual_EC_DRBG; future research may provide additional details about point Q and associated attacks, and could potentially lead to a RECAST or REJECT of this CVE.

Remediation

There is no fixed version for Debian:11 openssl.

References

low severity

Directory Traversal

  • Vulnerable module: patch
  • Introduced through: patch@2.7.6-7

Detailed paths

  • Introduced through: php@latest patch@2.7.6-7

NVD Description

Note: Versions mentioned in the description apply to the upstream patch package.

Directory traversal vulnerability in util.c in GNU patch 2.6.1 and earlier allows user-assisted remote attackers to create or overwrite arbitrary files via a filename that is specified with a .. (dot dot) or full pathname, a related issue to CVE-2010-1679.

Remediation

There is no fixed version for Debian:11 patch.

References

low severity

Insufficiently Protected Credentials

  • Vulnerable module: curl
  • Introduced through: curl@7.74.0-1.3+deb11u3 and curl/libcurl4@7.74.0-1.3+deb11u3

Detailed paths

  • Introduced through: php@latest curl@7.74.0-1.3+deb11u3
  • Introduced through: php@latest curl/libcurl4@7.74.0-1.3+deb11u3

NVD Description

Note: Versions mentioned in the description apply to the upstream curl package.

When curl is instructed to get content using the metalink feature, and a user name and password are used to download the metalink XML file, those same credentials are then subsequently passed on to each of the servers from which curl will download or try to download the contents from. Often contrary to the user's expectations and intentions and without telling the user it happened.

Remediation

There is no fixed version for Debian:11 curl.

References

low severity

Cryptographic Issues

  • Vulnerable module: glib2.0/libglib2.0-0
  • Introduced through: glib2.0/libglib2.0-0@2.66.8-1

Detailed paths

  • Introduced through: php@latest glib2.0/libglib2.0-0@2.66.8-1

NVD Description

Note: Versions mentioned in the description apply to the upstream glib2.0 package.

** DISPUTED ** GLib 2.31.8 and earlier, when the g_str_hash function is used, computes hash values without restricting the ability to trigger hash collisions predictably, which allows context-dependent attackers to cause a denial of service (CPU consumption) via crafted input to an application that maintains a hash table. NOTE: this issue may be disputed by the vendor; the existence of the g_str_hash function is not a vulnerability in the library, because callers of g_hash_table_new and g_hash_table_new_full can specify an arbitrary hash function that is appropriate for the application.

Remediation

There is no fixed version for Debian:11 glib2.0.

References

low severity

Information Exposure

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.31-13+deb11u5, glibc/libc-dev-bin@2.31-13+deb11u5 and others

Detailed paths

  • Introduced through: php@latest glibc/libc-bin@2.31-13+deb11u5
  • Introduced through: php@latest glibc/libc-dev-bin@2.31-13+deb11u5
  • Introduced through: php@latest glibc/libc6@2.31-13+deb11u5
  • Introduced through: php@latest glibc/libc6-dev@2.31-13+deb11u5

NVD Description

Note: Versions mentioned in the description apply to the upstream glibc package.

** DISPUTED ** GNU Libc current is affected by: Mitigation bypass. The impact is: Attacker may bypass ASLR using cache of thread stack and heap. The component is: glibc. NOTE: Upstream comments indicate "this is being treated as a non-security bug and no real threat."

Remediation

There is no fixed version for Debian:11 glibc.

References

low severity

Use of Insufficiently Random Values

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.31-13+deb11u5, glibc/libc-dev-bin@2.31-13+deb11u5 and others

Detailed paths

  • Introduced through: php@latest glibc/libc-bin@2.31-13+deb11u5
  • Introduced through: php@latest glibc/libc-dev-bin@2.31-13+deb11u5
  • Introduced through: php@latest glibc/libc6@2.31-13+deb11u5
  • Introduced through: php@latest glibc/libc6-dev@2.31-13+deb11u5

NVD Description

Note: Versions mentioned in the description apply to the upstream glibc package.

** DISPUTED ** GNU Libc current is affected by: Mitigation bypass. The impact is: Attacker may guess the heap addresses of pthread_created thread. The component is: glibc. NOTE: the vendor's position is "ASLR bypass itself is not a vulnerability."

Remediation

There is no fixed version for Debian:11 glibc.

References

low severity

Cryptographic Issues

  • Vulnerable module: openldap/libldap-2.4-2
  • Introduced through: openldap/libldap-2.4-2@2.4.57+dfsg-3+deb11u1

Detailed paths

  • Introduced through: php@latest openldap/libldap-2.4-2@2.4.57+dfsg-3+deb11u1

NVD Description

Note: Versions mentioned in the description apply to the upstream openldap package.

The nss_parse_ciphers function in libraries/libldap/tls_m.c in OpenLDAP does not properly parse OpenSSL-style multi-keyword mode cipher strings, which might cause a weaker than intended cipher to be used and allow remote attackers to have unspecified impact via unknown vectors.

Remediation

There is no fixed version for Debian:11 openldap.

References

low severity

Inadequate Encryption Strength

  • Vulnerable module: openssl
  • Introduced through: openssl@1.1.1n-0+deb11u3 and openssl/libssl1.1@1.1.1n-0+deb11u3

Detailed paths

  • Introduced through: php@latest openssl@1.1.1n-0+deb11u3
  • Introduced through: php@latest openssl/libssl1.1@1.1.1n-0+deb11u3

NVD Description

Note: Versions mentioned in the description apply to the upstream openssl package.

AES OCB mode for 32-bit x86 platforms using the AES-NI assembly optimised implementation will not encrypt the entirety of the data under some circumstances. This could reveal sixteen bytes of data that was preexisting in the memory that wasn't written. In the special case of "in place" encryption, sixteen bytes of the plaintext would be revealed. Since OpenSSL does not support OCB based cipher suites for TLS and DTLS, they are both unaffected. Fixed in OpenSSL 3.0.5 (Affected 3.0.0-3.0.4). Fixed in OpenSSL 1.1.1q (Affected 1.1.1-1.1.1p).

Remediation

There is no fixed version for Debian:11 openssl.

References

low severity

Cryptographic Issues

  • Vulnerable module: openssl
  • Introduced through: openssl@1.1.1n-0+deb11u3 and openssl/libssl1.1@1.1.1n-0+deb11u3

Detailed paths

  • Introduced through: php@latest openssl@1.1.1n-0+deb11u3
  • Introduced through: php@latest openssl/libssl1.1@1.1.1n-0+deb11u3

NVD Description

Note: Versions mentioned in the description apply to the upstream openssl package.

OpenSSL 0.9.8i on the Gaisler Research LEON3 SoC on the Xilinx Virtex-II Pro FPGA uses a Fixed Width Exponentiation (FWE) algorithm for certain signature calculations, and does not verify the signature before providing it to a caller, which makes it easier for physically proximate attackers to determine the private key via a modified supply voltage for the microprocessor, related to a "fault-based attack."

Remediation

There is no fixed version for Debian:11 openssl.

References

low severity

Race Condition

  • Vulnerable module: coreutils/coreutils
  • Introduced through: coreutils/coreutils@8.32-4+b1

Detailed paths

  • Introduced through: php@latest coreutils/coreutils@8.32-4+b1

NVD Description

Note: Versions mentioned in the description apply to the upstream coreutils package.

In GNU Coreutils through 8.29, chown-core.c in chown and chgrp does not prevent replacement of a plain file with a symlink during use of the POSIX "-R -L" options, which allows local users to modify the ownership of arbitrary files by leveraging a race condition.

Remediation

There is no fixed version for Debian:11 coreutils.

References

low severity

Improper Initialization

  • Vulnerable module: openldap/libldap-2.4-2
  • Introduced through: openldap/libldap-2.4-2@2.4.57+dfsg-3+deb11u1

Detailed paths

  • Introduced through: php@latest openldap/libldap-2.4-2@2.4.57+dfsg-3+deb11u1

NVD Description

Note: Versions mentioned in the description apply to the upstream openldap package.

slapd in OpenLDAP 2.4.45 and earlier creates a PID file after dropping privileges to a non-root account, which might allow local users to kill arbitrary processes by leveraging access to this non-root account for PID file modification before a root script executes a "kill cat /pathname" command, as demonstrated by openldap-initscript.

Remediation

There is no fixed version for Debian:11 openldap.

References

low severity

Time-of-check Time-of-use (TOCTOU)

  • Vulnerable module: shadow/login
  • Introduced through: shadow/login@1:4.8.1-1 and shadow/passwd@1:4.8.1-1

Detailed paths

  • Introduced through: php@latest shadow/login@1:4.8.1-1
  • Introduced through: php@latest shadow/passwd@1:4.8.1-1

NVD Description

Note: Versions mentioned in the description apply to the upstream shadow package.

shadow: TOCTOU (time-of-check time-of-use) race condition when copying and removing directory trees

Remediation

There is no fixed version for Debian:11 shadow.

References

low severity

Link Following

  • Vulnerable module: systemd/libsystemd0
  • Introduced through: systemd/libsystemd0@247.3-7+deb11u1 and systemd/libudev1@247.3-7+deb11u1

Detailed paths

  • Introduced through: php@latest systemd/libsystemd0@247.3-7+deb11u1
  • Introduced through: php@latest systemd/libudev1@247.3-7+deb11u1

NVD Description

Note: Versions mentioned in the description apply to the upstream systemd package.

systemd, when updating file permissions, allows local users to change the permissions and SELinux security contexts for arbitrary files via a symlink attack on unspecified files.

Remediation

There is no fixed version for Debian:11 systemd.

References

low severity

Resource Management Errors

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.31-13+deb11u5, glibc/libc-dev-bin@2.31-13+deb11u5 and others

Detailed paths

  • Introduced through: php@latest glibc/libc-bin@2.31-13+deb11u5
  • Introduced through: php@latest glibc/libc-dev-bin@2.31-13+deb11u5
  • Introduced through: php@latest glibc/libc6@2.31-13+deb11u5
  • Introduced through: php@latest glibc/libc6-dev@2.31-13+deb11u5

NVD Description

Note: Versions mentioned in the description apply to the upstream glibc package.

The glob implementation in the GNU C Library (aka glibc or libc6) allows remote authenticated users to cause a denial of service (CPU and memory consumption) via crafted glob expressions that do not match any pathnames, as demonstrated by glob expressions in STAT commands to an FTP daemon, a different vulnerability than CVE-2010-2632.

Remediation

There is no fixed version for Debian:11 glibc.

References

low severity

Inadequate Encryption Strength

  • Vulnerable module: gnutls28/libgnutls30
  • Introduced through: gnutls28/libgnutls30@3.7.1-5+deb11u2

Detailed paths

  • Introduced through: php@latest gnutls28/libgnutls30@3.7.1-5+deb11u2

NVD Description

Note: Versions mentioned in the description apply to the upstream gnutls28 package.

The SSL protocol, as used in certain configurations in Microsoft Windows and Microsoft Internet Explorer, Mozilla Firefox, Google Chrome, Opera, and other products, encrypts data by using CBC mode with chained initialization vectors, which allows man-in-the-middle attackers to obtain plaintext HTTP headers via a blockwise chosen-boundary attack (BCBA) on an HTTPS session, in conjunction with JavaScript code that uses (1) the HTML5 WebSocket API, (2) the Java URLConnection API, or (3) the Silverlight WebClient API, aka a "BEAST" attack.

Remediation

There is no fixed version for Debian:11 gnutls28.

References

low severity

Memory Leak

  • Vulnerable module: sqlite3/libsqlite3-0
  • Introduced through: sqlite3/libsqlite3-0@3.34.1-3

Detailed paths

  • Introduced through: php@latest sqlite3/libsqlite3-0@3.34.1-3

NVD Description

Note: Versions mentioned in the description apply to the upstream sqlite3 package.

** DISPUTED ** A Memory Leak vulnerability exists in SQLite Project SQLite3 3.35.1 and 3.37.0 via maliciously crafted SQL Queries (made via editing the Database File), it is possible to query a record, and leak subsequent bytes of memory that extend beyond the record, which could let a malicious user obtain sensitive information. NOTE: The developer disputes this as a vulnerability stating that If you give SQLite a corrupted database file and submit a query against the database, it might read parts of the database that you did not intend or expect.

Remediation

There is no fixed version for Debian:11 sqlite3.

References

low severity

Improper Certificate Validation

  • Vulnerable module: openldap/libldap-2.4-2
  • Introduced through: openldap/libldap-2.4-2@2.4.57+dfsg-3+deb11u1

Detailed paths

  • Introduced through: php@latest openldap/libldap-2.4-2@2.4.57+dfsg-3+deb11u1

NVD Description

Note: Versions mentioned in the description apply to the upstream openldap package.

libldap in certain third-party OpenLDAP packages has a certificate-validation flaw when the third-party package is asserting RFC6125 support. It considers CN even when there is a non-matching subjectAltName (SAN). This is fixed in, for example, openldap-2.4.46-10.el8 in Red Hat Enterprise Linux.

Remediation

There is no fixed version for Debian:11 openldap.

References

low severity

CVE-2004-0971

  • Vulnerable module: krb5/libgssapi-krb5-2
  • Introduced through: krb5/libgssapi-krb5-2@1.18.3-6+deb11u2, krb5/libk5crypto3@1.18.3-6+deb11u2 and others

Detailed paths

  • Introduced through: php@latest krb5/libgssapi-krb5-2@1.18.3-6+deb11u2
  • Introduced through: php@latest krb5/libk5crypto3@1.18.3-6+deb11u2
  • Introduced through: php@latest krb5/libkrb5-3@1.18.3-6+deb11u2
  • Introduced through: php@latest krb5/libkrb5support0@1.18.3-6+deb11u2

NVD Description

Note: Versions mentioned in the description apply to the upstream krb5 package.

The krb5-send-pr script in the kerberos5 (krb5) package in Trustix Secure Linux 1.5 through 2.1, and possibly other operating systems, allows local users to overwrite files via a symlink attack on temporary files.

Remediation

There is no fixed version for Debian:11 krb5.

References

low severity

Improper Verification of Cryptographic Signature

  • Vulnerable module: apt
  • Introduced through: apt@2.2.4 and apt/libapt-pkg6.0@2.2.4

Detailed paths

  • Introduced through: php@latest apt@2.2.4
  • Introduced through: php@latest apt/libapt-pkg6.0@2.2.4

NVD Description

Note: Versions mentioned in the description apply to the upstream apt package.

It was found that apt-key in apt, all versions, do not correctly validate gpg keys with the master keyring, leading to a potential man-in-the-middle attack.

Remediation

There is no fixed version for Debian:11 apt.

References

low severity

Out-of-bounds Read

  • Vulnerable module: binutils
  • Introduced through: binutils@2.35.2-2, binutils/binutils-common@2.35.2-2 and others

Detailed paths

  • Introduced through: php@latest binutils@2.35.2-2
  • Introduced through: php@latest binutils/binutils-common@2.35.2-2
  • Introduced through: php@latest binutils/binutils-x86-64-linux-gnu@2.35.2-2
  • Introduced through: php@latest binutils/libbinutils@2.35.2-2
  • Introduced through: php@latest binutils/libctf-nobfd0@2.35.2-2
  • Introduced through: php@latest binutils/libctf0@2.35.2-2

NVD Description

Note: Versions mentioned in the description apply to the upstream binutils package.

An issue was discovered in the Binary File Descriptor (BFD) library (aka libbfd), as distributed in GNU Binutils 2.35.1. A heap-based buffer over-read can occur in bfd_getl_signed_32 in libbfd.c because sh_entsize is not validated in _bfd_elf_slurp_secondary_reloc_section in elf.c.

Remediation

There is no fixed version for Debian:11 binutils.

References

low severity

Out-of-bounds Read

  • Vulnerable module: libsepol/libsepol1
  • Introduced through: libsepol/libsepol1@3.1-1

Detailed paths

  • Introduced through: php@latest libsepol/libsepol1@3.1-1

NVD Description

Note: Versions mentioned in the description apply to the upstream libsepol package.

The CIL compiler in SELinux 3.2 has a heap-based buffer over-read in ebitmap_match_any (called indirectly from cil_check_neverallow). This occurs because there is sometimes a lack of checks for invalid statements in an optional block.

Remediation

There is no fixed version for Debian:11 libsepol.

References

low severity

Use After Free

  • Vulnerable module: libsepol/libsepol1
  • Introduced through: libsepol/libsepol1@3.1-1

Detailed paths

  • Introduced through: php@latest libsepol/libsepol1@3.1-1

NVD Description

Note: Versions mentioned in the description apply to the upstream libsepol package.

The CIL compiler in SELinux 3.2 has a use-after-free in __cil_verify_classperms (called from __verify_map_perm_classperms and hashtab_map).

Remediation

There is no fixed version for Debian:11 libsepol.

References

low severity

Use After Free

  • Vulnerable module: libsepol/libsepol1
  • Introduced through: libsepol/libsepol1@3.1-1

Detailed paths

  • Introduced through: php@latest libsepol/libsepol1@3.1-1

NVD Description

Note: Versions mentioned in the description apply to the upstream libsepol package.

The CIL compiler in SELinux 3.2 has a use-after-free in __cil_verify_classperms (called from __cil_verify_classpermission and __cil_pre_verify_helper).

Remediation

There is no fixed version for Debian:11 libsepol.

References

low severity

Use After Free

  • Vulnerable module: libsepol/libsepol1
  • Introduced through: libsepol/libsepol1@3.1-1

Detailed paths

  • Introduced through: php@latest libsepol/libsepol1@3.1-1

NVD Description

Note: Versions mentioned in the description apply to the upstream libsepol package.

The CIL compiler in SELinux 3.2 has a use-after-free in cil_reset_classpermission (called from cil_reset_classperms_set and cil_reset_classperms_list).

Remediation

There is no fixed version for Debian:11 libsepol.

References

low severity
new

CVE-2022-3715

  • Vulnerable module: bash
  • Introduced through: bash@5.1-2+deb11u1

Detailed paths

  • Introduced through: php@latest bash@5.1-2+deb11u1

NVD Description

This vulnerability has not been analyzed by NVD yet.

Remediation

There is no fixed version for Debian:11 bash.

References

low severity

CVE-2022-32221

  • Vulnerable module: curl
  • Introduced through: curl@7.74.0-1.3+deb11u3 and curl/libcurl4@7.74.0-1.3+deb11u3

Detailed paths

  • Introduced through: php@latest curl@7.74.0-1.3+deb11u3
  • Introduced through: php@latest curl/libcurl4@7.74.0-1.3+deb11u3

NVD Description

This vulnerability has not been analyzed by NVD yet.

Remediation

There is no fixed version for Debian:11 curl.

References

low severity
new

CVE-2022-42898

  • Vulnerable module: krb5/libgssapi-krb5-2
  • Introduced through: krb5/libgssapi-krb5-2@1.18.3-6+deb11u2, krb5/libk5crypto3@1.18.3-6+deb11u2 and others
  • Fixed in: 1.18.3-6+deb11u3

Detailed paths

  • Introduced through: php@latest krb5/libgssapi-krb5-2@1.18.3-6+deb11u2
  • Introduced through: php@latest krb5/libk5crypto3@1.18.3-6+deb11u2
  • Introduced through: php@latest krb5/libkrb5-3@1.18.3-6+deb11u2
  • Introduced through: php@latest krb5/libkrb5support0@1.18.3-6+deb11u2

NVD Description

This vulnerability has not been analyzed by NVD yet.

Remediation

Upgrade Debian:11 krb5 to version 1.18.3-6+deb11u3 or higher.

References