webpack-require-from

v1.8.1

Webpack plugin that allows to configure path or URL for fetching dynamic imports

MIT
Latest version published 8 months ago
    npm install webpack-require-from
  

Explore Similar Packages

Package Health Score

59 / 100
  • Popularity
    Small
  • Maintenance
    Inactive
  • Security
    No known security issues
  • Community
    Sustainable

Popularity

Small
Weekly Downloads (6,991)
Dependents
15
GitHub Stars
128
Forks
17
Contributors
5

The npm package webpack-require-from receives a total of 6,991 downloads a week. As such, we scored webpack-require-from popularity level to be Small.

Based on project statistics from the GitHub repository for the npm package webpack-require-from, we found that it has been starred 128 times, and that 15 other projects on the ecosystem are dependent on it.

Downloads are calculated as moving averages for a period of the last 12 months, excluding weekends and known missing data points.

Security

No known security issues

Security and license risk for recent versions


Direct Vulnerabilities

1.5.0
1.7.0-beta.0
1.7.0
1.8.0
1.8.1
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L

Indirect Vulnerabilities

1.5.0
1.7.0-beta.0
1.7.0
1.8.0
1.8.1
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L

License Risks

1.5.0
1.7.0-beta.0
1.7.0
1.8.0
1.8.1
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L

Security Policy
No
All security vulnerabilities belong to production dependencies of direct and indirect packages.

You can connect your project's repository to Snyk to stay up to date on security alerts and receive automatic fix pull requests.

We found a way for you to contribute to the project! Looks like webpack-require-from is missing a security policy.

    # Install the Snyk CLI and test your project
npm i snyk && snyk test webpack-require-from
Fix it in your project with Snyk!

Maintenance

Inactive
Commit Frequency
Open Issues
2
Merged PR
13
Open PR
1
Last Commit
9 days ago

Further analysis of the maintenance status of webpack-require-from based on released npm versions cadence, the repository activity, and other data points determined that its maintenance is Inactive.

We found that webpack-require-from demonstrates a positive version release cadence with at least one new version released in the past 12 months.

As a healthy sign for on-going project maintenance, we found that the GitHub repository had at least 1 pull request or issue interacted with by the community.

Community

Sustainable
Readme.md
Yes
Contributing.md
No
Code of Conduct
No
Contributors
5
Funding
Yes
License
MIT

This project has seen only 10 or less contributors.

We found a way for you to contribute to the project! Looks like webpack-require-from is missing a Code of Conduct.

Package

Node.js Compatibility
not defined

Age
4 years
Dependencies
0 Direct / 0 Total
Versions
18
Install Size
21.8 kB
Dist-tags
1
# of Files
8
Maintainers
1
TS Typings
No

webpack-require-from has more than a single and default latest tag published for the npm package. This means, there may be other tags available for this package, such as next to indicate future releases, or stable to indicate stable releases.