pouchdb-auth

v4.2.0

A PouchDB plug-in that simulates CouchDB's authentication daemon. Includes a users db that functions like CouchDB's.

Apache-2.0
Latest version published 3 years ago
    npm install pouchdb-auth
  
We couldn't find any similar packages Browse all packages

Package Health Score

57 / 100

Security

No known security issues
Powered by Snyk
All security vulnerabilities belong to production dependencies of direct and indirect packages.

Security and license risk for significant versions

All Versions
Version Vulnerabilities License Risk
4.2.0 | 09/2019
Popular
  • 0
    C
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
4.1.0 | 08/2018
  • 0
    H
  • 0
    M
  • 0
    L
3.0.1 | 06/2017
  • 0
    H
  • 0
    M
  • 0
    L
2.1.1 | 08/2016
  • 0
    H
  • 0
    M
  • 0
    L
2.0.1 | 03/2016
  • 0
    H
  • 0
    M
  • 0
    L
License
Apache-2.0
Security Policy
No

Is your project affected by vulnerabilities?

Scan your projects for vulnerabilities. Fix quickly with automated fixes. Get started with Snyk for free.

# Install the Snyk CLI and test your project
npm i snyk -g && snyk test pouchdb-auth
Get started free

Popularity

Small

Weekly Downloads (4,039)

Download trend
Dependents
0
GitHub Stars
882
Forks
163
Contributors
60

Direct Usage Popularity

Occasionally

The npm package pouchdb-auth receives a total of 4,039 downloads a week. As such, we scored pouchdb-auth popularity level to be Small.

Based on project statistics from the GitHub repository for the npm package pouchdb-auth, we found that it has been starred 882 times, and that 0 other projects in the ecosystem are dependent on it.

Downloads are calculated as moving averages for a period of the last 12 months, excluding weekends and known missing data points.

Community

Sustainable
Readme.md
Yes
Contributing.md
Yes
Code of Conduct
No
Contributors
60
Funding
No

With more than 10 contributors for the pouchdb-auth repository, this is possibly a sign for a growing and inviting community.

We found a way for you to contribute to the project! Looks like pouchdb-auth is missing a Code of Conduct.


Embed Package Health Score Badge

package health: 57/100 package health 57/100

Maintenance

Inactive

Commit Frequency

No Recent Commits
Open Issues
118
Open PR
23
Last Release
3 years ago
Last Commit
1 year ago

Further analysis of the maintenance status of pouchdb-auth based on released npm versions cadence, the repository activity, and other data points determined that its maintenance is Inactive.

An important project maintenance signal to consider for pouchdb-auth is that it hasn't seen any new versions released to npm in the past 12 months, and could be considered as a discontinued project, or that which receives low attention from its maintainers.

In the past month we didn't find any pull request activity or change in issues status has been detected for the GitHub repository.

Package

Node.js Compatibility
not defined

Age
8 years
Dependencies
12 Direct
Versions
17
Install Size
337 kB
Dist-tags
1
# of Files
10
Maintainers
6
TS Typings
No

pouchdb-auth has more than a single and default latest tag published for the npm package. This means, there may be other tags available for this package, such as next to indicate future releases, or stable to indicate stable releases.