postcode-validator

v3.7.0

Validate postcodes based on country

MIT
Latest version published 3 months ago
    npm install postcode-validator
  
We couldn't find any similar packages Browse all packages

Package Health Score

75 / 100

Security

No known security issues
Powered by Snyk
All security vulnerabilities belong to production dependencies of direct and indirect packages.

Security and license risk for significant versions

All Versions
Version Vulnerabilities License Risk
3.7.0 | 05/2022
  • 0
    C
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
3.6.6 | 03/2022
Popular
  • 0
    C
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
2.1.0 | 11/2019
  • 0
    C
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
1.2.1 | 02/2019
  • 0
    C
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
1.1.6 | 05/2015
  • 0
    C
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
License
MIT
Security Policy
No

Is your project affected by vulnerabilities?

Scan your projects for vulnerabilities. Fix quickly with automated fixes. Get started with Snyk for free.

# Install the Snyk CLI and test your project
npm i snyk -g && snyk test postcode-validator
Get started free

Popularity

Recognized

Weekly Downloads (18,731)

Download trend
Dependents
5
GitHub Stars
49
Forks
33
Contributors
20

Direct Usage Popularity

Occasionally

The npm package postcode-validator receives a total of 18,731 downloads a week. As such, we scored postcode-validator popularity level to be Recognized.

Based on project statistics from the GitHub repository for the npm package postcode-validator, we found that it has been starred 49 times, and that 5 other projects in the ecosystem are dependent on it.

Downloads are calculated as moving averages for a period of the last 12 months, excluding weekends and known missing data points.

Community

Sustainable
Readme.md
Yes
Contributing.md
Yes
Code of Conduct
No
Contributors
20
Funding
No

With more than 10 contributors for the postcode-validator repository, this is possibly a sign for a growing and inviting community.

We found a way for you to contribute to the project! Looks like postcode-validator is missing a Code of Conduct.


Embed Package Health Score Badge

package health: 75/100 package health 75/100

Maintenance

Healthy

Commit Frequency

Open Issues
0
Open PR
1
Last Release
3 months ago
Last Commit
3 months ago

Further analysis of the maintenance status of postcode-validator based on released npm versions cadence, the repository activity, and other data points determined that its maintenance is Healthy.

We found that postcode-validator demonstrates a positive version release cadence with at least one new version released in the past 3 months.

In the past month we didn't find any pull request activity or change in issues status has been detected for the GitHub repository.

Package

Node.js Compatibility
not defined

Age
7 years
Dependencies
0 Direct
Versions
39
Install Size
37.6 kB
Dist-tags
1
# of Files
15
Maintainers
1
TS Typings
Yes

postcode-validator has more than a single and default latest tag published for the npm package. This means, there may be other tags available for this package, such as next to indicate future releases, or stable to indicate stable releases.