multiselect-react-dropdown

v1.6.1

React multiselect dropdown component with search and various features

MIT
Latest version published 2 months ago
    npm install multiselect-react-dropdown
  
We couldn't find any similar packages Browse all packages

Package Health Score

67 / 100
  • Popularity
    Small
  • Maintenance
    Sustainable
  • Security
    No known security issues
  • Community
    Sustainable

Popularity

Small
Weekly Downloads (7,973)
Dependents
4
GitHub Stars
55
Forks
29
Contributors
6

The npm package multiselect-react-dropdown receives a total of 7,973 downloads a week. As such, we scored multiselect-react-dropdown popularity level to be Small.

Based on project statistics from the GitHub repository for the npm package multiselect-react-dropdown, we found that it has been starred 55 times, and that 4 other projects on the ecosystem are dependent on it.

Downloads are calculated as moving averages for a period of the last 12 months, excluding weekends and known missing data points.

Security

No known security issues

Security and license risk for significant versions

All Versions

Direct Vulnerabilities

1.2.9
1.3.2
1.4.11
1.5.8
1.6.1
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L

Indirect Vulnerabilities

1.2.9
1.3.2
1.4.11
1.5.8
1.6.1
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L

License Risks

1.2.9
1.3.2
1.4.11
1.5.8
1.6.1
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
All security vulnerabilities belong to production dependencies of direct and indirect packages.

Security Policy
No

You can connect your project's repository to Snyk to stay up to date on security alerts and receive automatic fix pull requests.

We found a way for you to contribute to the project! Looks like multiselect-react-dropdown is missing a security policy.

    # Install the Snyk CLI and test your project
npm i snyk && snyk test multiselect-react-dropdown
Fix it in your project with Snyk!

Maintenance

Sustainable
Commit Frequency
Open Issues
27
Merged PR
9
Open PR
0
Last Commit
2 months ago

Further analysis of the maintenance status of multiselect-react-dropdown based on released npm versions cadence, the repository activity, and other data points determined that its maintenance is Sustainable.

We found that multiselect-react-dropdown demonstrates a positive version release cadence with at least one new version released in the past 3 months.

As a healthy sign for on-going project maintenance, we found that the GitHub repository had at least 1 pull request or issue interacted with by the community.

Community

Sustainable
Readme.md
Yes
Contributing.md
No
Code of Conduct
No
Contributors
6
Funding
No
License
MIT

This project has seen only 10 or less contributors.

We found a way for you to contribute to the project! Looks like multiselect-react-dropdown is missing a Code of Conduct.


Embed Package Health Score Badge

Package Health (67.42857142857144/100)

Package

Node.js Compatibility
not defined

Age
2 years
Dependencies
2 Direct / 8 Total
Versions
5
Install Size
303 kB
Dist-tags
1
# of Files
27
Maintainers
1
TS Typings
No

We detected a total of 8 direct & transitive dependencies for multiselect-react-dropdown. See the full dependency tree of multiselect-react-dropdown

multiselect-react-dropdown has more than a single and default latest tag published for the npm package. This means, there may be other tags available for this package, such as next to indicate future releases, or stable to indicate stable releases.