mini-next

v2.0.13-beta2

mini-next零成本升级react服务端渲染方案,支持静态导出,cdn部署,前后端同构,自定义路由前缀,自定义webpack,服务端渲染缓存

MIT
Latest version published 15 days ago
    npm install mini-next
  

Package Health Score

60 / 100
  • Popularity
    Limited
  • Maintenance
    Healthy
  • Security
    Security review needed
  • Community
    Limited

Popularity

Limited
Weekly Downloads (60)
Dependents
2
GitHub Stars
15
Forks
6
Contributors
1

The npm package mini-next receives a total of 60 downloads a week. As such, we scored mini-next popularity level to be Limited.

Based on project statistics from the GitHub repository for the npm package mini-next, we found that it has been starred 15 times, and that 2 other projects on the ecosystem are dependent on it.

Downloads are calculated as moving averages for a period of the last 12 months, excluding weekends and known missing data points.

Security

Security review needed

Security and license risk for recent versions


Direct Vulnerabilities

2.0.11
2.0.12-beta1
2.0.12
2.0.13-beta1
2.0.13-beta2
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L

Indirect Vulnerabilities

2.0.11
2.0.12-beta1
2.0.12
2.0.13-beta1
2.0.13-beta2
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L

License Risks

2.0.11
2.0.12-beta1
2.0.12
2.0.13-beta1
2.0.13-beta2
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L

Security Policy
No
All security vulnerabilities belong to production dependencies of direct and indirect packages.

Snyk detected that the latest version of mini-next has a security vulnerability.

We highly advise you to review these security issues.

You can connect your project's repository to Snyk to stay up to date on security alerts and receive automatic fix pull requests.

We found a way for you to contribute to the project! Looks like mini-next is missing a security policy.

    # Install the Snyk CLI and test your project
npm i snyk && snyk test mini-next
Fix it in your project with Snyk!

Maintenance

Healthy
Commit Frequency
Open Issues
0
Merged PR
8
Open PR
0
Last Commit
15 days ago

Further analysis of the maintenance status of mini-next based on released npm versions cadence, the repository activity, and other data points determined that its maintenance is Healthy.

We found that mini-next demonstrates a positive version release cadence with at least one new version released in the past 3 months.

In the past month we didn't find any pull request activity or change in issues status has been detected for the GitHub repository.

Community

Limited
Readme.md
Yes
Contributing.md
No
Code of Conduct
No
Contributors
1
Funding
No
License
MIT

This project has seen only 10 or less contributors.

We found a way for you to contribute to the project! Looks like mini-next is missing a Code of Conduct.

Package

Node.js Compatibility
not defined

Age
5 months
Dependencies
70 Direct / 1.25K Total
Versions
5
Install Size
139 kB
Dist-tags
1
# of Files
50
Maintainers
2
TS Typings
No

We detected a total of 1245 direct & transitive dependencies for mini-next. See the full dependency tree of mini-next

mini-next has more than a single and default latest tag published for the npm package. This means, there may be other tags available for this package, such as next to indicate future releases, or stable to indicate stable releases.