lumigo-cli

v0.47.0

A collection of helpful commands for working with AWS Lambda

Apache-2.0
Latest version published about 2 months ago
    npm install lumigo-cli
  
We couldn't find any similar packages Browse all packages

Package Health Score

57 / 100
  • Popularity
    Limited
  • Maintenance
    Sustainable
  • Security
    Security review needed
  • Community
    Sustainable

Popularity

Limited
Weekly Downloads (439)
Dependents
0
GitHub Stars
207
Forks
10
Contributors
4

The npm package lumigo-cli receives a total of 439 downloads a week. As such, we scored lumigo-cli popularity level to be Limited.

Based on project statistics from the GitHub repository for the npm package lumigo-cli, we found that it has been starred 207 times, and that 0 other projects on the ecosystem are dependent on it.

Downloads are calculated as moving averages for a period of the last 12 months, excluding weekends and known missing data points.

Security

Security review needed

Security and license risk for significant versions

All Versions

Direct Vulnerabilities

0.43.0
0.44.1
0.45.0
0.46.2
0.47.0
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L

Indirect Vulnerabilities

0.43.0
0.44.1
0.45.0
0.46.2
0.47.0

License Risks

0.43.0
0.44.1
0.45.0
0.46.2
0.47.0
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
All security vulnerabilities belong to production dependencies of direct and indirect packages.

Security Policy
No

Snyk detected that the latest version of lumigo-cli has a security vulnerability.

We highly advise you to review these security issues.

You can connect your project's repository to Snyk to stay up to date on security alerts and receive automatic fix pull requests.

We found a way for you to contribute to the project! Looks like lumigo-cli is missing a security policy.

    # Install the Snyk CLI and test your project
npm i snyk && snyk test lumigo-cli
Fix it in your project with Snyk!

Maintenance

Sustainable
Commit Frequency
Open Issues
17
Merged PR
32
Open PR
2
Last Commit
2 months ago

Further analysis of the maintenance status of lumigo-cli based on released npm versions cadence, the repository activity, and other data points determined that its maintenance is Sustainable.

We found that lumigo-cli demonstrates a positive version release cadence with at least one new version released in the past 3 months.

As a healthy sign for on-going project maintenance, we found that the GitHub repository had at least 1 pull request or issue interacted with by the community.

Community

Sustainable
Readme.md
Yes
Contributing.md
No
Code of Conduct
No
Contributors
4
Funding
No
License
Apache-2.0

This project has seen only 10 or less contributors.

We found a way for you to contribute to the project! Looks like lumigo-cli is missing a Code of Conduct.


Embed Package Health Score Badge

package health: 57/100 package health 57/100

Package

Node.js Compatibility
>=8.12.0

Age
1 year
Dependencies
22 Direct / 330 Total
Versions
5
Install Size
209 kB
Dist-tags
1
# of Files
50
Maintainers
1
TS Typings
No

We detected a total of 330 direct & transitive dependencies for lumigo-cli. See the full dependency tree of lumigo-cli

lumigo-cli has more than a single and default latest tag published for the npm package. This means, there may be other tags available for this package, such as next to indicate future releases, or stable to indicate stable releases.