lite-server

v2.5.4

Lightweight development node server for serving a web app, providing a fallback for browser history API, loading in the browser, and injecting scripts on the fly.

MIT
Latest version published about 1 year ago
    npm install lite-server
  

Package Health Score

50 / 100
  • Popularity
    Recognized
  • Maintenance
    Inactive
  • Security
    Security review needed
  • Community
    Sustainable

Popularity

Recognized
Weekly Downloads (36,904)
Dependents
2.01K
GitHub Stars
1.88K
Forks
229
Contributors
11

The npm package lite-server receives a total of 36,904 downloads a week. As such, we scored lite-server popularity level to be Recognized.

Based on project statistics from the GitHub repository for the npm package lite-server, we found that it has been starred 1,882 times, and that 2,006 other projects on the ecosystem are dependent on it.

Downloads are calculated as moving averages for a period of the last 12 months, excluding weekends and known missing data points.

Security

Security review needed

Security and license risk for recent versions


Direct Vulnerabilities

2.5.0
2.5.1
2.5.2
2.5.3
2.5.4
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L

Indirect Vulnerabilities

2.5.0
2.5.1
2.5.2
2.5.3
2.5.4

License Risks

2.5.0
2.5.1
2.5.2
2.5.3
2.5.4
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L

Security Policy
No
All security vulnerabilities belong to production dependencies of direct and indirect packages.

Snyk detected that the latest version of lite-server has a security vulnerability.

We highly advise you to review these security issues.

You can connect your project's repository to Snyk to stay up to date on security alerts and receive automatic fix pull requests.

We found a way for you to contribute to the project! Looks like lite-server is missing a security policy.

    # Install the Snyk CLI and test your project
npm i snyk && snyk test lite-server
Fix it in your project with Snyk!

Maintenance

Inactive
Commit Frequency
No Recent Commits
Open Issues
53
Merged PR
27
Open PR
10
Last Commit
1 year ago

Further analysis of the maintenance status of lite-server based on released npm versions cadence, the repository activity, and other data points determined that its maintenance is Inactive.

An important project maintenance signal to consider for lite-server is that it hasn't seen any new versions released to npm in the past 12 months, and could be considered as a discontinued project, or that which receives low attention from its maintainers.

As a healthy sign for on-going project maintenance, we found that the GitHub repository had at least 1 pull request or issue interacted with by the community.

Community

Sustainable
Readme.md
Yes
Contributing.md
No
Code of Conduct
No
Contributors
11
Funding
Yes
License
MIT

With more than 10 contributors for the lite-server repository, this is possibly a sign for a growing and inviting community.

We found a way for you to contribute to the project! Looks like lite-server is missing a Code of Conduct.

Package

Node.js Compatibility
not defined

Age
7 years
Dependencies
5 Direct / 200 Total
Versions
5
Install Size
24.1 kB
Dist-tags
1
# of Files
14
Maintainers
1
TS Typings
No

We detected a total of 200 direct & transitive dependencies for lite-server. See the full dependency tree of lite-server

lite-server has more than a single and default latest tag published for the npm package. This means, there may be other tags available for this package, such as next to indicate future releases, or stable to indicate stable releases.